]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: pass CFLAGS and LDFLAGS
authorFahad Usman <fahad_usman@mentor.com>
Wed, 12 Dec 2012 11:26:11 +0000 (16:26 +0500)
committerSaul Wold <sgw@linux.intel.com>
Fri, 14 Dec 2012 23:17:20 +0000 (15:17 -0800)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
the patch was imported from meta-mentor layer on yoctoproject git server
http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit id
9d698004137c1a888d40d6a4808d94afa22387e7

Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/perf/perf_3.4.bb

index 4e6d03d00507a7faf7a37d455dbbac94651e9d6a..8d1b2324b393c59da1cbf9f5b30b835067b18b76 100644 (file)
@@ -9,7 +9,7 @@ as well."
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
 
-PR = "r6"
+PR = "r8"
 
 require perf.inc
 
@@ -67,6 +67,14 @@ EXTRA_OEMAKE = \
                NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${SCRIPTING_DEFINES} \
                '
 
+# We already pass the correct arguments to our compiler for the CFLAGS (if we
+# don't override it, it'll add -m32/-m64 itself). For LDFLAGS, it was failing
+# to find bfd symbols.
+EXTRA_OEMAKE += "\
+       'CFLAGS=${CFLAGS}' \
+       'LDFLAGS=${LDFLAGS} -lpthread -lrt -lelf -lm -lbfd' \
+"
+
 do_compile() {
        oe_runmake all
 }