]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: glib-2.0: don't apply qsort_r test removable patch for native version
authorSimon Busch <morphis@gravedo.de>
Tue, 1 Nov 2011 22:08:10 +0000 (23:08 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 2 Nov 2011 09:08:21 +0000 (09:08 +0000)
On some buildhosts with an older version of native glib-2.0 installed (in this case
2.16.6) the qsort_r test removable patch leads to a compilation error:

| ./.libs/libglib-2.0.so: undefined reference to `qsort_r'
| collect2: ld returned 1 exit status

This patch fixes this so the patch gets only applied for the native version of this
recipe.

Signed-off-by: Simon Busch <morphis@gravedo.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-2.0/glib-2.0_2.30.0.bb

index 566355d9deff490f696b2bcf52aed04b16a8a114..0efce406e0a6d582b48b25ae14304f3557ad807f 100644 (file)
@@ -1,6 +1,6 @@
 require glib.inc
 
-PR = "r2"
+PR = "r3"
 PE = "1"
 
 DEPENDS += "libffi python-argparse-native"
@@ -9,11 +9,14 @@ DEPENDS_virtclass-nativesdk += "libffi-nativesdk python-argparse-native zlib-nat
 
 SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
 
+QSORT_PATCH = "file://remove.test.for.qsort_r.patch"
+QSORT_PATCH_virtclass-native = ""
+
 SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.bz2 \
            file://configure-libtool.patch \
            file://60_wait-longer-for-threads-to-die.patch \
            file://g_once_init_enter.patch \
-           file://remove.test.for.qsort_r.patch \
+           ${QSORT_PATCH} \
           "
 SRC_URI[md5sum] = "fee101d9d7daa8ddfbae00325f307f3b"
 SRC_URI[sha256sum] = "ca9c731017ab370859e847f8b70079bc6dcf389dc0ccb0d0419925aff81b9687"