]> code.ossystems Code Review - openembedded-core.git/commitdiff
dosfstools_2.11: fix build following removal of -e from EXTRA_OEMAKE
authorAndre McCurdy <armccurdy@gmail.com>
Fri, 26 Feb 2016 05:24:38 +0000 (21:24 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 28 Feb 2016 11:32:41 +0000 (11:32 +0000)
Also misc formatting tweaks to align with v3.0.28 recipe and remove
BBCLASSEXTEND = "native" (native builds should always use the GPLv3
recipe).

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/dosfstools/dosfstools_2.11.bb

index beec488c092da637186dc452782c9ca9f027505b..176504d4f3cdde38fef430195a8120f447524d8f 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
 # Released under the MIT license (see packages/COPYING)
 SUMMARY = "DOS FAT Filesystem Utilities"
-HOMEPAGE = "http://daniel-baumann.ch/software/dosfstools/"
+HOMEPAGE = "https://github.com/dosfstools/dosfstools"
 
 SECTION = "base"
 LICENSE = "GPLv2"
@@ -18,21 +18,17 @@ SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/${BPN}/${BP}.src.tar.gz/407d4
            file://include-linux-types.patch \
            file://nofat32_autoselect.patch \
            file://fix_populated_dosfs_creation.patch \
-          file://0001-Include-fcntl.h-for-getting-loff_t-definition.patch \
-          "
+           file://0001-Include-fcntl.h-for-getting-loff_t-definition.patch \
+"
 
 SRC_URI[md5sum] = "407d405ade410f7597d364ab5dc8c9f6"
 SRC_URI[sha256sum] = "0eac6d12388b3d9ed78684529c1b0d9346fa2abbe406c4d4a3eb5a023c98a484"
 
-# Makefile sets this, but we clobber its CFLAGS, so
-# add this in here to for sure allow for big files.
-#
-CFLAGS_append = " -D_FILE_OFFSET_BITS=64"
-CFLAGS_append_libc-musl = " -D_GNU_SOURCE"
+CFLAGS += "-D_GNU_SOURCE ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', '', d)}"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
 
 do_install () {
        oe_runmake "PREFIX=${D}" "SBINDIR=${D}${base_sbindir}" \
                   "MANDIR=${D}${mandir}/man8" install
 }
-
-BBCLASSEXTEND = "native"