]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-git: move shared parts from mesa-dri_git to mesa-git.inc and add mesa-xlib_git
authorMartin Jansa <Martin.Jansa@gmail.com>
Thu, 13 Oct 2011 08:41:53 +0000 (10:41 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 14 Oct 2011 11:20:27 +0000 (12:20 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
meta/recipes-graphics/mesa/mesa-dri_git.bb
meta/recipes-graphics/mesa/mesa-git.inc [new file with mode: 0644]
meta/recipes-graphics/mesa/mesa-xlib_git.bb [new file with mode: 0644]

index 14852133ae6e43c3080f049feb9550b675afa0e6..9c2c6a1b41a4748bed6382f2f1b65b2bd4fb2727 100644 (file)
@@ -1,36 +1,7 @@
 include mesa-common.inc
+include mesa-git.inc
 include mesa-dri.inc
-
-SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
-           file://cross2.patch \
-           file://matypes.h"
-#           file://mesa-DRI2Swapbuffer.patch "
-S = "${WORKDIR}/git"
-
-SRCREV = "1bf94d419805538ac23a4d0b04d31ac5e4487aca"
-PV = "7.7+git${SRCPV}"
 PR = "${INC_PR}.0"
 
-PACKAGES =+ "${PN}-xprogs"
-
-FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
-
-do_configure_prepend () {
-    cp ${WORKDIR}/matypes.h ${S}/src/mesa/x86
-    touch ${S}/src/mesa/x86/matypes.h
-}
-
-do_compile () {
-       oe_runmake clean
-       oe_runmake -C src/glsl CC='${BUILD_CC}' CFLAGS=""
-       mv ${S}/src/glsl/apps/compile ${S}/host_compile
-       oe_runmake clean
-       oe_runmake GLSL_CL="${S}/host_compile"
-}
-
-do_install_append () {
-    install -d ${D}/usr/bin
-    install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
-}
-
 COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+
diff --git a/meta/recipes-graphics/mesa/mesa-git.inc b/meta/recipes-graphics/mesa/mesa-git.inc
new file mode 100644 (file)
index 0000000..2f27ef1
--- /dev/null
@@ -0,0 +1,30 @@
+SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
+           file://cross2.patch \
+           file://matypes.h"
+#           file://mesa-DRI2Swapbuffer.patch "
+S = "${WORKDIR}/git"
+
+SRCREV = "1bf94d419805538ac23a4d0b04d31ac5e4487aca"
+PV = "7.7+git${SRCPV}"
+
+PACKAGES =+ "${PN}-xprogs"
+
+FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
+
+do_configure_prepend () {
+    cp ${WORKDIR}/matypes.h ${S}/src/mesa/x86
+    touch ${S}/src/mesa/x86/matypes.h
+}
+
+do_compile () {
+       oe_runmake clean
+       oe_runmake -C src/glsl CC='${BUILD_CC}' CFLAGS=""
+       mv ${S}/src/glsl/apps/compile ${S}/host_compile
+       oe_runmake clean
+       oe_runmake GLSL_CL="${S}/host_compile"
+}
+
+do_install_append () {
+    install -d ${D}/usr/bin
+    install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
+}
diff --git a/meta/recipes-graphics/mesa/mesa-xlib_git.bb b/meta/recipes-graphics/mesa/mesa-xlib_git.bb
new file mode 100644 (file)
index 0000000..7f827a7
--- /dev/null
@@ -0,0 +1,4 @@
+include mesa-common.inc
+include mesa-git.inc
+include mesa-xlib.inc
+PR = "${INC_PR}.0"