]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit-inittab: support non-busybox-getty on serial consoles
authorAndré Draszik <andre.draszik@jci.com>
Mon, 11 Feb 2019 11:21:06 +0000 (11:21 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 12 Feb 2019 14:04:24 +0000 (14:04 +0000)
Busybox' getty has code to try to make itself a session leader,
whereas util-linux' agetty doesn't. It expects this to happen
from outside.
When getty is not a session leader, many things don't work on
the serial console, e.g. setting the terminal process group,
job control doesn't work, etc.

Executing image tests also fails with AssertionErrors, because
    Feb  5 16:12:55 qemuarm getty[590]: /dev/ttyAMA1: cannot get controlling tty: Operation not permitted
    Feb  5 16:12:55 qemuarm getty[590]: /dev/ttyAMA1: cannot set process group: Inappropriate ioctl for device

Update the start_getty script to invoke getty via the setsid
utility if needed, i.e. if /sbin/getty is not busybox getty.

[YOCTO #13058]

Signed-off-by: André Draszik <andre.draszik@jci.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/sysvinit/sysvinit-inittab/start_getty
meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb

index e15ae35f903733003f00b98199b6eff3d1c2e805..96fd6cfcfd0bc47bce6fc9613d46fccf9a08919b 100644 (file)
@@ -13,6 +13,18 @@ active_serial=$(grep "serial" /proc/tty/drivers | cut -d/ -f1 | sed "s/ *$//")
 # Rephrase input parameter from ttyS target index (ttyS1, ttyS2, ttyAMA0, etc).
 runtime_tty=$(echo $2 | grep -oh '[0-9]')
 
+# busybox' getty does this itself, util-linux' agetty needs extra help
+getty="/sbin/getty"
+case $(readlink -f "${getty}") in
+    */busybox*)
+        ;;
+    *)
+        if [ -x "/usr/bin/setsid" ] ; then
+            setsid="/usr/bin/setsid"
+        fi
+        ;;
+esac
+
 # Backup $IFS.
 DEFAULT_IFS=$IFS
 # Customize Internal Field Separator.
@@ -31,7 +43,7 @@ for line in $active_serial; do
                        then
                                if [ -c /dev/$2 ]
                                then
-                                   /sbin/getty -L $1 $2 $3
+                                   ${setsid:-} ${getty} -L $1 $2 $3
                                fi
                                break
                        fi
index 8585a418ab8def45a06bdfc88d0983d01f5bada7..bfd890d924b8b394fe6093e61221ac7a07c47fef 100644 (file)
@@ -20,6 +20,7 @@ do_install() {
     install -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
     install -d ${D}${base_bindir}
     install -m 0755 ${WORKDIR}/start_getty ${D}${base_bindir}/start_getty
+    sed -e 's,/usr/bin,${bindir},g' -i ${D}${base_bindir}/start_getty
 
     set -x
     tmp="${SERIAL_CONSOLES}"