]> code.ossystems Code Review - openembedded-core.git/commitdiff
Directly make use of the OEROOT environment variable in the default local.conf, and...
authorChris Larson <kergoth@openedhand.com>
Sun, 27 Aug 2006 09:07:44 +0000 (09:07 +0000)
committerChris Larson <kergoth@openedhand.com>
Sun, 27 Aug 2006 09:07:44 +0000 (09:07 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@650 311d38ba-8fff-0310-9ca6-ca027cbcb966

build/conf/local.conf [moved from build/conf/local.conf.sample with 86% similarity, mode: 0644]
poky-init-build-env

old mode 100755 (executable)
new mode 100644 (file)
similarity index 86%
rename from build/conf/local.conf.sample
rename to build/conf/local.conf
index 5de6ca6..83bd007
@@ -1,12 +1,12 @@
 # Where to cache the files OE downloads
-DL_DIR = "POKYROOT/sources"
-BBFILES := "POKYROOT/meta/packages/*/*.bb"
+DL_DIR = "${OEROOT}/sources"
+BBFILES = "${OEROOT}/meta/packages/*/*.bb"
 
 # To enable extra packages, uncomment the following lines:
-# BBFILES := "POKYROOT/meta/packages/*/*.bb POKYROOT/meta-extras/packages/*/*.bb"
+# BBFILES := "${OEROOT}/meta/packages/*/*.bb ${OEROOT}/meta-extras/packages/*/*.bb"
 # BBFILE_COLLECTIONS = "normal extras"
-# BBFILE_PATTERN_normal = "^POKYROOT/meta/"
-# BBFILE_PATTERN_extras = "^POKYROOT/meta/"
+# BBFILE_PATTERN_normal = "^${OEROOT}/meta/"
+# BBFILE_PATTERN_extras = "^${OEROOT}/meta/"
 # BBFILE_PRIORITY_normal = "5"
 # BBFILE_PRIORITY_extras = "5"
 
@@ -34,7 +34,7 @@ DISTRO_TYPE = "debug"
 # Note that a full build of everything in OpenEmbedded will take GigaBytes of hard
 # disk space, so make sure to free enough space. The default TMPDIR is
 # <build directory>/tmp
-# TMPDIR = /usr/local/projects/oetmp
+TMPDIR = "${OEROOT}/build/tmp"
 
 # Uncomment these two if you want BitBake to build images useful for debugging.
 # DEBUG_BUILD = "1"
index 6cda775ffe040ad5afdea6aec4b6330a77ecbacd..b9be03fb3cd9f52f5d85a387a8a388d9614372dc 100755 (executable)
@@ -49,12 +49,6 @@ if ! (test -d $BBDIR && test -d $PKGDIR && test -d $BUILDDIR); then
     exit 1
 fi
 
-if ! (test -r $BUILDDIR/conf/local.conf); then
-   cat $BUILDDIR/conf/local.conf.sample | sed -e"s|POKYROOT|${OEROOT}|g" > $BUILDDIR/conf/local.conf
-   echo
-   echo "..Created initial 'build/conf/local.conf'"
-fi     
-
 BBPATH=$BBDIR
 if test x"$BBDIR" != x"$PKGDIR"; then
        BBPATH=$PKGDIR:$BBPATH
@@ -74,4 +68,4 @@ export LANG=C
 
 echo
 echo "### Shell environment set up for Poky builds. ###"
-echo 
\ No newline at end of file
+echo