]> code.ossystems Code Review - openembedded-core.git/commitdiff
documentation/handbook: Tweak Makefiles and paths after path changes
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 15 Oct 2010 11:14:28 +0000 (12:14 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 15 Oct 2010 11:14:28 +0000 (12:14 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
documentation/poky-ref-manual/Makefile
documentation/poky-ref-manual/bsp-guide.xml
documentation/poky-ref-manual/poky-handbook.xml
documentation/template/fop-config.xml
documentation/tools/poky-docbook-to-pdf

index 0ee87a133c6f3af4895387a20ce13612f3f5178a..5c5761c401ff9bc3078a338601eff4ac4369caa8 100644 (file)
@@ -1,12 +1,12 @@
 all: html pdf tarball
 
 pdf:
-       cd ..; ./tools/poky-docbook-to-pdf ./poky-ref-manual/poky-handbook.xml ./template
-       cd ..; ./tools/poky-docbook-to-pdf ./poky-ref-manual/bsp-guide.xml ./template
+       ../tools/poky-docbook-to-pdf poky-handbook.xml ../template
+       ../tools/poky-docbook-to-pdf bsp-guide.xml ../template
 
 XSLTOPTS = --stringparam html.stylesheet style.css \
            --stringparam  chapter.autolabel 1 \
-           --stringparam  appendix.autolabel 1 \
+           --stringparam  appendix.autolabel A \
            --stringparam  section.autolabel 1 \
            --stringparam  section.label.includes.component.label 1 \
           --xinclude
index 2f4906c17365fe85aa7dd6ef47a00ec4fed350ba..a1752bf535382237348fe07fddeff085bd1531ae 100644 (file)
@@ -9,7 +9,7 @@
 
         <mediaobject>
             <imageobject>
-                <imagedata fileref='template/poky-handbook.png' 
+                <imagedata fileref='poky-handbook.png' 
                     format='SVG' 
                     align='center' scalefit='1' width='100%'/>
             </imageobject>    
index fb2bc80df30bf0746e3330b275ff23e67b15ad18..445217c7864f07a8471dc98666360d6d638245c8 100644 (file)
@@ -9,7 +9,7 @@
 
         <mediaobject>
             <imageobject>
-                <imagedata fileref='template/poky-handbook.png' 
+                <imagedata fileref='poky-handbook.png' 
                     format='SVG' 
                     align='center' scalefit='1' width='100%'/>
             </imageobject>    
index 7d56223d17707ca04f5539c0a0146b40fa76066a..09cc5ca0f57d7611f2fec9f861d72a57aa352021 100644 (file)
@@ -10,8 +10,8 @@
     Set the baseDir so common/openedhand.svg references in plans still
     work ok. Note, relative file references to current dir should still work.
     -->        
-  <base>template</base>
-  <font-base>template</font-base>
+  <base>../template</base>
+  <font-base>../template</font-base>
  
   <!-- Source resolution in dpi (dots/pixels per inch) for determining the
        size of pixels in SVG and bitmap images, default: 72dpi -->
index aa221c02bcebf83e3e0ffe1a172f0cd313b595d0..9ac0b828cf44619e123f8829b7df73a0f12c6cbb 100755 (executable)
@@ -30,11 +30,15 @@ xsltproc --xinclude                    \
          --stringparam  body.font.master  9 \
          --stringparam  title.font.master  11 \
          --stringparam draft.watermark.image "$TEMPLATEDIR/draft.png" \
+         --stringparam  chapter.autolabel 1 \
+         --stringparam  appendix.autolabel A \
+         --stringparam  section.autolabel 1 \
+         --stringparam  section.label.includes.component.label 1 \
          --output $FO               \
          $TEMPLATEDIR/poky-db-pdf.xsl    \
         $1                 || exit 1
 
-echo fop -c $TEMPLATEDIR/fop-config.xml -fo $FO -pdf $PDF       || exit 1
+
 fop -c $TEMPLATEDIR/fop-config.xml -fo $FO -pdf $PDF       || exit 1
 
 rm -f $FO