]> code.ossystems Code Review - openembedded-core.git/commitdiff
findutils (GPLv2): remove metadata sharing from GPLv3 recipe
authorKevin Tian <kevin.tian@intel.com>
Tue, 24 Aug 2010 07:17:20 +0000 (15:17 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 27 Aug 2010 12:04:38 +0000 (13:04 +0100)
to avoid inadvertent contamination in the future, GPLv2 recipe is
fully split its v3 buddy. This way we can enforce strong isolation
for GPLv2 code.

also remove one unnecessary patch

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/packages/findutils/findutils-4.2.31/mkdir.patch [deleted file]
meta/packages/findutils/findutils_4.2.31.bb

diff --git a/meta/packages/findutils/findutils-4.2.31/mkdir.patch b/meta/packages/findutils/findutils-4.2.31/mkdir.patch
deleted file mode 100644 (file)
index 98ffbd2..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: findutils-4.2.29/configure.in
-===================================================================
---- findutils-4.2.29.orig/configure.in 2006-11-25 18:06:00.000000000 +0000
-+++ findutils-4.2.29/configure.in      2009-08-19 18:01:06.000000000 +0100
-@@ -209,6 +209,8 @@
- dnl Hence they need to know if they are being compiled into findutils or not.
- AC_DEFINE([FINDUTILS], 1, [Define if we are compiling GNU findutils])
-+MKINSTALLDIRS="mkdir -p"
-+AC_SUBST(MKINSTALLDIRS)
- # This is necessary so that .o files in LIBOBJS are also built via
- # the ANSI2KNR-filtering rules.
-Index: findutils-4.2.29/po/Makefile.in.in
-===================================================================
---- findutils-4.2.29.orig/po/Makefile.in.in    2009-08-19 18:05:47.000000000 +0100
-+++ findutils-4.2.29/po/Makefile.in.in 2009-08-19 18:05:58.000000000 +0100
-@@ -30,7 +30,7 @@
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
- MKINSTALLDIRS = @MKINSTALLDIRS@
--mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
-+mkinstalldirs = $(MKINSTALLDIRS)
- GMSGFMT = @GMSGFMT@
- MSGFMT = @MSGFMT@
index 3f4fc534cc77335856fd795db925d79c683ab763..2804a3ba3a512645fbb86e57c6d9f01caf7e563a 100644 (file)
@@ -1,17 +1,29 @@
-require findutils.inc
+DESCRIPTION = "find, locate, and xargs binaries."
+HOMEPAGE = "http://www.gnu.org/software/findutils/"
+BUGTRACKER = "http://savannah.gnu.org/bugs/?group=findutils"
+SECTION = "console/utils"
 
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-PR = "r0"
+PR = "r1"
 
-SRC_URI += "file://mkdir.patch \
-            file://gnulib-extension.patch"
+SRC_URI = "${GNU_MIRROR}/findutils/findutils-${PV}.tar.gz \
+           file://gnulib-extension.patch"
+
+inherit autotools gettext
+
+# diffutils assumes non-glibc compilation with uclibc and
+# this causes it to generate its own implementations of
+# standard functionality.  regex.c actually breaks compilation
+# because it uses __mempcpy, there are other things (TBD:
+# see diffutils.mk in buildroot)
+EXTRA_OECONF_linux-uclibc = "--without-included-regex"
 
 do_install_append () {
-        if [ -e ${D}${bindir}/find ]; then
-            mv ${D}${bindir}/find ${D}${bindir}/find.${PN}
-            mv ${D}${bindir}/xargs ${D}${bindir}/xargs.${PN}
-        fi
+       if [ -e ${D}${bindir}/find ]; then
+               mv ${D}${bindir}/find ${D}${bindir}/find.${PN}
+               mv ${D}${bindir}/xargs ${D}${bindir}/xargs.${PN}
+       fi
 }
 
 pkg_postinst_${PN} () {