]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: fix parallel make
authorQing He <qing.he@intel.com>
Thu, 17 Feb 2011 07:16:02 +0000 (15:16 +0800)
committerSaul Wold <sgw@linux.intel.com>
Fri, 18 Feb 2011 01:25:22 +0000 (17:25 -0800)
Signed-off-by: Qing He <qing.he@intel.com>
meta/recipes-connectivity/openssl/openssl-0.9.8p/parallel-make-fix.patch [new file with mode: 0644]
meta/recipes-connectivity/openssl/openssl.inc
meta/recipes-connectivity/openssl/openssl_0.9.8p.bb

diff --git a/meta/recipes-connectivity/openssl/openssl-0.9.8p/parallel-make-fix.patch b/meta/recipes-connectivity/openssl/openssl-0.9.8p/parallel-make-fix.patch
new file mode 100644 (file)
index 0000000..60fab9d
--- /dev/null
@@ -0,0 +1,18 @@
+fix the parallel build regarding shared libraries.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/Makefile.org b/Makefile.org
+index 2fb0309..8bec3d0 100644
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -352,6 +352,9 @@ all_testapps: build_libs build_testapps
+ build_testapps:
+       @dir=crypto; target=testapps; $(BUILD_ONE_CMD)
++libcrypto.a: build_crypto
++libssl.a: build_ssl
++
+ build_shared: $(SHARED_LIBS)
+ libcrypto$(SHLIB_EXT): libcrypto.a $(SHARED_FIPS)
+       @if [ "$(SHLIB_TARGET)" != "" ]; then \
index f054c26ca646b7f746122ed935450c3360863990..68b3d7bd0afd509e490c3b8637ce27ef40e4eef8 100644 (file)
@@ -10,7 +10,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=83d26c69f6f0172ee7f795790424b453"
 
 DEPENDS = "perl-native"
 
-SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz"
+SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
+           file://parallel-make-fix.patch \
+          "
 S = "${WORKDIR}/openssl-${PV}"
 
 AR_append = " r"
@@ -29,8 +31,6 @@ export DIRS = "crypto ssl apps"
 export EX_LIBS = "-lgcc -ldl"
 export AS = "${CC} -c"
 
-PARALLEL_MAKE = ""
-
 inherit pkgconfig siteinfo
 
 PACKAGES =+ "libcrypto libssl"
index 283b82add0175ac17a9a5cf9e4b337815af75084..f42b3cbf6b0af36344c1ad764e215753f3f8a2c0 100644 (file)
@@ -1,6 +1,6 @@
 require openssl.inc
 
-PR = "r2"
+PR = "r3"
 SRC_URI += "file://debian/ca.patch \
             file://debian/config-hurd.patch;apply=no \
             file://debian/debian-targets.patch \