]> code.ossystems Code Review - openembedded-core.git/commitdiff
update-modules: update script to read /etc/modules-load.d/ directory
authorMartin Jansa <martin.jansa@gmail.com>
Fri, 23 Mar 2012 14:37:23 +0000 (15:37 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 23 Mar 2012 17:47:14 +0000 (17:47 +0000)
* show warning for old /etc/modutils/* files without .conf extension
* v2: keep adding modules also from old /etc/modutils/* after showing
  warning, this way update-modules will be backward compatible also on
  images without kernel upgrade

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/update-modules/update-modules-1.0/update-modules
meta/recipes-kernel/update-modules/update-modules_1.0.bb

index 7ee7df81924ac958085403a828099dd69c6ef912..99040a1ab482f179e2da8ff49ea6869cef1b302d 100755 (executable)
@@ -103,8 +103,8 @@ createfile() {
 $HEADER"
 #
 # Please do not edit this file directly. If you want to change or add
-# anything please take a look at the files in /etc/modutils and read
-# the manpage for update-modules.
+# anything please take a look at the files in /etc/modutils, /etc/modules-load.d 
+# and read the manpage for update-modules.
 #
 EOF
 }
@@ -161,12 +161,23 @@ fi
 createfile "$MODCONFTMPFILE"
 createfile "$MODULESTMPFILE"
 
+# well we're using /etc/modprobe.d/*.conf instead of /etc/modutils/*.conf anyway..
 for cfg in /etc/modutils/* $CONF ; do
        if [ -f "$cfg" ]; then # this check is necesarry to skip /etc/modutils/archs
                if echo $cfg | grep -q '\.dpkg-[a-z]*\|~$' ; then
                        true
                elif echo $cfg | grep -q '\.conf$' ; then
                        addfile "$cfg" "$MODCONFTMPFILE"
+               else
+                       echo "Please migrate your $cfg file to /etc/modules-load.d/*.conf"
+                       addfile "$cfg" "$MODULESTMPFILE"
+               fi
+       fi
+done
+for cfg in /etc/modules-load.d/*.conf; do
+       if [ -f "$cfg" ]; then # this check is necesarry to skip weird entries
+               if echo $cfg | grep -q '\.dpkg-[a-z]*\|~$' ; then
+                       true
                else
                        addfile "$cfg" "$MODULESTMPFILE"
                fi
index d9697de6c35cede0045e00c5ada1b77f8961e0f7..2af75e6a9954a196e9c209160b0b1325c8cae513 100644 (file)
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa
 
 RDEPENDS_${PN} = "module-init-tools-depmod"
 
-PR = "r12"
+PR = "r13"
 
 SRC_URI = "file://update-modules \
            file://COPYING.GPL"