]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: fix file permission for /etc/pam.d/sshd
authorChen Qi <Qi.Chen@windriver.com>
Mon, 19 Oct 2015 03:16:40 +0000 (11:16 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 21 Oct 2015 21:51:47 +0000 (22:51 +0100)
The file permission should be 0644 instead of 0755.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-connectivity/openssh/openssh_7.1p1.bb

index eeeb4b4c732bc3b67bbae0dbd008d61d00d43a06..40938cc08c99c5aa9bdf1c1c0e366a0a952918ee 100644 (file)
@@ -87,7 +87,7 @@ do_compile_ptest() {
 
 do_install_append () {
        if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
-               install -D -m 0755 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd
+               install -D -m 0644 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd
                sed -i -e 's:#UsePAM no:UsePAM yes:' ${WORKDIR}/sshd_config ${D}${sysconfdir}/ssh/sshd_config
        fi