]> code.ossystems Code Review - openembedded-core.git/commitdiff
connman-gnome: Fix WiFi security display issue
authorDongxiao Xu <dongxiao.xu@intel.com>
Wed, 31 Aug 2011 06:47:33 +0000 (14:47 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Aug 2011 18:44:53 +0000 (19:44 +0100)
Latest connman-0.75 change the WiFi security type, causing the
incompatibility of connman-gnome. Fix connman-gnome accordingly to show
the correct security informtion.

[YOCTO #1343]

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/connman/connman-gnome/security-type.patch [new file with mode: 0644]
meta/recipes-connectivity/connman/connman-gnome_0.5.bb

diff --git a/meta/recipes-connectivity/connman/connman-gnome/security-type.patch b/meta/recipes-connectivity/connman/connman-gnome/security-type.patch
new file mode 100644 (file)
index 0000000..a75d696
--- /dev/null
@@ -0,0 +1,41 @@
+From ec36df9d1fbb6dcbf0d1e79245ffe213049ecd5a Mon Sep 17 00:00:00 2001
+From: Dongxiao Xu <dongxiao.xu@intel.com>
+Date: Wed, 3 Aug 2011 14:33:07 +0800
+Subject: [PATCH] connman-dbus: fix security type mismatch
+
+Latest connman change the Security type to be array{String}, fix
+connman-gnome accordingly.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+---
+ common/connman-dbus.c |    5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+Upstream-Status: Pending
+
+diff --git a/common/connman-dbus.c b/common/connman-dbus.c
+index 0f4e1db..0ac8ed5 100644
+--- a/common/connman-dbus.c
++++ b/common/connman-dbus.c
+@@ -384,7 +384,8 @@ static void service_changed(DBusGProxy *proxy, const char *property,
+               gtk_tree_store_set(store, &iter,
+                                       CONNMAN_COLUMN_FAVORITE, favorite, -1);
+       } else if (g_str_equal(property, "Security") == TRUE) {
+-              const char *security = value ? g_value_get_string(value) : NULL;
++              const char **array = value ? g_value_get_boxed(value) : NULL;
++              const char *security = g_strjoinv(" ", array);
+               gtk_tree_store_set(store, &iter,
+                                       CONNMAN_COLUMN_SECURITY, security,
+                                       -1);
+@@ -487,7 +488,7 @@ static void service_properties(DBusGProxy *proxy, GHashTable *hash,
+       strength = value ? g_value_get_uchar(value) : 0;
+       value = g_hash_table_lookup(hash, "Security");
+-      security = value ? g_value_get_string(value) : NULL;
++      security = value ? g_strjoinv(" ", g_value_get_boxed(value)) : NULL;
+       value = g_hash_table_lookup(hash, "PassPhrase");
+       passphrase = value ? g_value_get_string(value) : NULL;
+-- 
+1.7.1
+
index 416fa4b27c4602b2367bdaaf7929a201b5054c0e..9c78186211d8f677ab7e5fe09a5b7057e2c8eca0 100644 (file)
@@ -8,11 +8,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
 
 DEPENDS = "gtk+ dbus"
 
-PR = "r6"
+PR = "r7"
 
 SRCREV = "78d3c39db6f3f7977b466305110faa8ca5f74ec8"
 SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman-gnome.git;protocol=git \
-           file://3g.patch"
+           file://3g.patch \
+           file://security-type.patch"
 
 S = "${WORKDIR}/git"