]> code.ossystems Code Review - openembedded-core.git/commitdiff
Remove unneeded packages/meta files
authorRichard Purdie <richard@openedhand.com>
Tue, 4 Jul 2006 20:18:25 +0000 (20:18 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 4 Jul 2006 20:18:25 +0000 (20:18 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@500 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/meta/maemo-image.bb [deleted file]
openembedded/packages/meta/meta-maemo.bb [deleted file]
openembedded/packages/meta/mythfront-image.bb [deleted file]
openembedded/packages/meta/task-bootstrap.bb [deleted file]

diff --git a/openembedded/packages/meta/maemo-image.bb b/openembedded/packages/meta/maemo-image.bb
deleted file mode 100644 (file)
index 2adc88b..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-#
-# Meta package for maemo based system image
-#
-
-FEED_URIS_append_familiar   = " maemo##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/maemo"
-
-PR = "r2"
-
-export IMAGE_BASENAME = "maemo-image"
-
-GUI_MACHINE_CLASS ?= "none"
-
-MAEMO_EXTRA_DEPENDS = "scap dosfstools"
-MAEMO_EXTRA_INSTALL = "osso-af-services osso-af-base-apps scap dosfstools"
-
-XSERVER ?= "xserver-kdrive-omap"
-
-DEPENDS = "task-bootstrap \
-          meta-maemo \
-          ${MAEMO_EXTRA_DEPENDS}"
-
-export IPKG_INSTALL = "task-bootstrap maemo-task-base maemo-task-theme \
-                      maemo-task-apps ${MAEMO_EXTRA_INSTALL} \
-                      ${XSERVER}"
-
-inherit image_ipk
-LICENSE = MIT
diff --git a/openembedded/packages/meta/meta-maemo.bb b/openembedded/packages/meta/meta-maemo.bb
deleted file mode 100644 (file)
index fc0e985..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-
-PR          = "r7"
-PACKAGES    = maemo-task-base maemo-task-apps maemo-task-libs-install maemo-task-theme
-DESCRIPTION = "Meta-package for maemo environment"
-MAINTAINER  = "Florian Boor <florian@kernelconcepts.de>"
-
-ALLOW_EMPTY = "1"
-
-maemo-base-depends = "\
-    diet-x11 \
-    virtual/xserver \
-    xpext \
-    xsp"
-
-RDEPENDS_maemo-base-depends := "${maemo-base-depends}"
-DEPENDS += " ${maemo-base-depends}"
-
-maemo-task-libs-install = "\
-                           libsqlite0 \
-                           libhildonlgpl0 \
-                           libhildonbase0 \
-                           libhildonwidgets0 \
-                           libhildonfm1"
-
-RDEPENDS_maemo-task-libs-install := "${maemo-task-libs-install}"
-
-
-maemo-task-base = "\
-    bluez-utils-dbus \
-    matchbox \
-    shared-mime-info \
-    rxvt-unicode \
-    xst \
-    xhost \
-    xrdb \
-    libgtkstylus \
-    detect-stylus \
-    outo \
-    hildon-initscripts \
-    libosso \
-    osso-af-utils \
-    osso-af-startup \
-    osso-core-config \
-    osso-gnome-vfs2 \
-    osso-thumbnail \
-    xauth \
-    esd"
-
-RDEPENDS_maemo-task-base := "gdk-pixbuf-loader-png \
-                          gdk-pixbuf-loader-xpm \
-                          gdk-pixbuf-loader-jpeg \
-                          pango-module-basic-x \
-                          pango-module-basic-fc \
-                          ${maemo-task-base}"
-
-DEPENDS += " ${maemo-task-base}"
-
-
-maemo-task-theme = "\
-    xcursor-transparent-theme \
-    sdk-default-theme \
-    sdk-default-theme-config \
-    sdk-default-icons \
-    sapwood \
-    ttf-bitstream-vera \
-    sapwood \
-    osso-sounds"
-
-RDEPENDS_maemo-task-theme := "${maemo-task-theme}"
-
-DEPENDS += " ${maemo-task-theme}"
-
-
-
-maemo-task-apps = "\
-    osso-gwobex \
-    osso-gwconnect \
-    osso-bttools \
-    hildon-status-bar \
-    hildon-home \
-    hildon-navigator \
-    hildon-control-panel \
-    osso-application-installer \
-    osso-app-killer \
-    osso-screenshot-tool \
-    gpe-todo-hildon \
-    gpe-contacts-hildon \
-    gpe-mini-browser-hildon"
-
-RDEPENDS_maemo-task-apps := "${maemo-task-apps}"
-DEPENDS += " ${maemo-task-apps}"
-
-LICENSE = "MIT"
diff --git a/openembedded/packages/meta/mythfront-image.bb b/openembedded/packages/meta/mythfront-image.bb
deleted file mode 100644 (file)
index 7836258..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-export IMAGE_BASENAME = "mythfront-image"
-
-IMAGE_ROOTFS_SIZE_ext2 = "85000"
-IMAGE_ROOTFS_SIZE_ext2.gz = "85000"
-IMAGE_LINGUAS = ""
-
-MYTHFRONT_PACKAGES = "task-bootstrap task-mythfront"
-
-export IPKG_INSTALL = "${MYTHFRONT_PACKAGES}"
-DEPENDS = "${MYTHFRONT_PACKAGES}"
-
-inherit image_ipk
-LICENSE = MIT
diff --git a/openembedded/packages/meta/task-bootstrap.bb b/openembedded/packages/meta/task-bootstrap.bb
deleted file mode 100644 (file)
index 497fc31..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "Core packages required for a basic installation"
-MAINTAINER = "Phil Blundell <pb@handhelds.org>"
-PR = "r26"
-
-# The BOOTSTRAP_EXTRA_ variables are often manipulated by the
-# MACHINE .conf files, so adjust PACKAGE_ARCH accordingly.
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-ALLOW_EMPTY = 1
-PACKAGES = "${PN}"
-
-MODUTILS ?= "24 26"
-
-def bootstrap_modutils_rdepends(d):
-       import bb
-        m = bb.data.getVar('MODUTILS', d, 1)
-        r = []
-       if '24' in m:
-                r.append('modutils-depmod')
-        if '26' in m:
-                r.append('module-init-tools-depmod')
-        return ' '.join(r)
-
-HOTPLUG ?= "linux-hotplug"
-
-RDEPENDS = 'base-files base-passwd busybox \
-       initscripts \
-       netbase sysvinit sysvinit-pidof tinylogin \
-       modutils-initscripts fuser setserial\
-       ${HOTPLUG} \
-       ${BOOTSTRAP_EXTRA_RDEPENDS} \
-       ${@bootstrap_modutils_rdepends(d)}'
-
-RRECOMMENDS = 'dropbear portmap \
-       ${BOOTSTRAP_EXTRA_RRECOMMENDS}'
-LICENSE = MIT