]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr-native: Set CONFIG_SHELL to /bin/bash
authorRobert Yang <liezhi.yang@windriver.com>
Mon, 10 Nov 2014 03:37:41 +0000 (19:37 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Nov 2014 15:36:12 +0000 (15:36 +0000)
The apr-native provides usr/share/build-1/libtool which is required by
the recipe such as apache2-native. If we don't set the CONFIG_SHELL to
/bin/bash, then:

1) If we build apr-native on a host which is "/bin/sh -> bash", the
   interpreter in usr/share/build-1/libtool would be "#!/bin/sh".
2) When we re-use apr-native's sstate on a host which is
   "/bin/sh -> dash", there would be errors.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/apr/apr_1.5.1.bb

index 17dddbce7e24bb66fbe3c689d50aa1826d8fe7db..49a08b026113337b63aa911add38ba6944214b11 100644 (file)
@@ -86,3 +86,5 @@ do_install_ptest() {
        cp ${S}/test/testall $t/
        cp ${S}/test/tryread $t/
 }
+
+export CONFIG_SHELL="/bin/bash"