]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdb: build with expat, add missing RRECOMMENDS_gdbserver
authorAndreas Oberritter <obi@opendreambox.org>
Mon, 2 Apr 2012 22:23:55 +0000 (00:23 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 Apr 2012 13:10:44 +0000 (14:10 +0100)
* Fixes communication between gdbserver and gdb-cross
  by using the same expat settings for both recipes.
* Adds missing build dependencies for expat/expat-native.
* Adds missing glibc-thread-db runtime recommendation
  to gdbserver, which was set only for gdb.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gdb/gdb-common.inc
meta/recipes-devtools/gdb/gdb-cross-canadian_7.4.bb
meta/recipes-devtools/gdb/gdb-cross.inc
meta/recipes-devtools/gdb/gdb-cross_7.4.bb

index 0833a030d4b7d4b03cd534820b48065450f28580..a8fca6f68113b724e645138eabcdc2bba0f960db 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "gdb - GNU debugger"
 HOMEPAGE = "http://www.gnu.org/software/gdb/"
 LICENSE="GPLv3+"
 SECTION = "devel"
-DEPENDS = "ncurses readline ${LTTNGUST}"
+DEPENDS = "expat ncurses readline ${LTTNGUST}"
 
 LTTNGUST = "lttng-ust"
 LTTNGUST_libc-uclibc = ""
@@ -11,7 +11,7 @@ LTTNGUST_mipsel = ""
 LTTNGUST_mips64 = ""
 LTTNGUST_mips64el = ""
 
-INC_PR = "r6"
+INC_PR = "r7"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
                file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674 \
@@ -36,7 +36,7 @@ B = "${WORKDIR}/build-${TARGET_SYS}"
 
 EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'"
 
-EXPAT = "--without-expat"
+EXPAT = "--with-expat"
 
 EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \
                 --with-curses --disable-multilib --with-system-readline --disable-sim \
@@ -63,4 +63,6 @@ do_install_append() {
 
 RRECOMMENDS_gdb_append_linux = " glibc-thread-db "
 RRECOMMENDS_gdb_append_linux-gnueabi = " glibc-thread-db "
+RRECOMMENDS_gdbserver_append_linux = " glibc-thread-db "
+RRECOMMENDS_gdbserver_append_linux-gnueabi = " glibc-thread-db "
 
index 8e68c757827645df069d781c5fccb9967fdb8010..b2f39ce9d3392246bb9dd2ef4524fd90b6fd3869 100644 (file)
@@ -4,6 +4,5 @@ require gdb-cross-canadian.inc
 PR = "${INC_PR}.5"
 
 GDBPROPREFIX = "--program-prefix='${TARGET_PREFIX}'"
-EXPAT = "--with-expat"
 
 S = "${WORKDIR}/${BPN}-${PV}"
index 20db86b563a5c47ae52e0aa0057e91dee4205808..588a208d94faf604e5325bfe6b4fb124088483a4 100644 (file)
@@ -1,6 +1,6 @@
 require gdb-common.inc
 
-DEPENDS = "ncurses-native"
+DEPENDS = "expat-native ncurses-native"
 
 #EXTRA_OEMAKE += "LDFLAGS='${BUILD_LDFLAGS}'"
 
index eaf8f36b06388d07c82de036c50d1ee0cd992970..a14d0ba952d7801268cc95617888e734af1f97bd 100644 (file)
@@ -1,7 +1,6 @@
 require gdb-cross.inc
 
 SRC_URI += "file://sim-install-6.6.patch"
-EXPAT = "--with-expat"
 
 PR = "${INC_PR}.0"