]> code.ossystems Code Review - openembedded-core.git/commitdiff
tinylogin: make it build against uclibc 0.9.29 (from OE)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 18 Jan 2008 14:43:25 +0000 (14:43 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 18 Jan 2008 14:43:25 +0000 (14:43 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3541 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/tinylogin/tinylogin-1.4/remove-index.patch [new file with mode: 0644]
meta/packages/tinylogin/tinylogin_1.4.bb

diff --git a/meta/packages/tinylogin/tinylogin-1.4/remove-index.patch b/meta/packages/tinylogin/tinylogin-1.4/remove-index.patch
new file mode 100644 (file)
index 0000000..fc35002
--- /dev/null
@@ -0,0 +1,11 @@
+--- /tmp/deluser.c     2007-05-13 10:38:19.000000000 +0200
++++ tinylogin-1.4/deluser.c    2007-05-13 10:38:50.185251000 +0200
+@@ -60,7 +60,7 @@
+       }
+       start++;
+-      stop = index(start, '\n');      /* index is a BSD-ism */
++      stop = strchr(start, '\n');     /* index is a BSD-ism, strchr hopefully isn't */
+       b.start = start - buffer;
+       b.stop = stop - buffer;
+       return b;
index 33f1c32aeda86fe5853e185e657df0c46d079dd3..ad254bff6a8df5076936728a19bae243f7b46d80 100644 (file)
@@ -5,12 +5,13 @@ changing passwords, and otherwise maintaining users \
 and groups on an embedded system."
 HOMEPAGE = "http://tinylogin.busybox.net/"
 LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://tinylogin.busybox.net/downloads/tinylogin-${PV}.tar.bz2 \
        file://cvs-20040608.patch;patch=1;pnum=1 \
        file://add-system.patch;patch=1;pnum=1 \
-       file://adduser-empty_pwd.patch;patch=1"
+       file://adduser-empty_pwd.patch;patch=1 \
+       file://remove-index.patch;patch=1"
 
 EXTRA_OEMAKE = ""