]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-demos: only enable glu when x11 in DISTRO_FEATURES
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 6 May 2015 09:17:08 +0000 (02:17 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 14 May 2015 10:41:11 +0000 (11:41 +0100)
Fixed when no x11 in DISTRO_FEATURES:
checking for GL/glu.h... no
configure: error: GLU not found

The GL/glu.h is provided by libglu, and libglu requires libGL.so which
is provided by mesa, but mesa doesn't build out libGL.so without x11 in
DISTRO_FEATURES, so only enable glu when x11 in DISTRO_FEATURES.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb

index 1caa50bc1bd6dac4ecbaedffda5931d0e3614b8a..e565442fc6731660e57aad6ce0e89441808e80d5 100644 (file)
@@ -25,8 +25,8 @@ SRC_URI[sha256sum] = "e4bfecb5816ddd4b7b37c1bc876b63f1f7f06fda5879221a9774d0952f
 
 inherit autotools pkgconfig
 
-PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 glu \
-                  ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew', '', d)}"
+PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
+                  ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew glu', '', d)}"
 
 # The Wayland code doesn't work with Wayland 1.0, so disable it for now
 #${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"