]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.1: powerclamp: APL CPU
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 13 Jun 2016 15:56:35 +0000 (11:56 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 15 Jun 2016 16:36:36 +0000 (17:36 +0100)
These patches backport the upstream changes for powerclamp to support APL APU.

  Dasaratharaman Chandramouli (1):
    intel powerclamp: support Knights Landing

  Jacob Pan (2):
    thermal/powerclamp: add cpu id for denlow platform
    thermal/powerclamp: remove cpu whitelist

  Radivoje Jovanovic (2):
    thermal/powerclamp: add cpu id for skylake h/s
    thermal/powerclamp: add cpu id for Skylake u/y

Signed-off-by: Yu, Ong Hock <ong.hock.yu@intel.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
meta/recipes-kernel/linux/linux-yocto_4.1.bb

index c609ddc92c3ce868a910a9f6363955ca95b96988..9eaecd4075c18c4e137b19e9cebd05aab7ceb607 100644 (file)
@@ -11,7 +11,7 @@ python () {
         raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "e34d6198589347504e6c8451fc999908f9ce4752"
+SRCREV_machine ?= "576bba030082fcdcdf9e58a285c92558f27d1e73"
 SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
index acdb0dc3c52adc6e0ed14fdb35318fe9a72dff98..7e0f66fa84cdb447692ffad689b08dc3cc843fce 100644 (file)
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.26"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
+SRCREV_machine ?= "9ba8c36e9ea7419d06accab5311e7fb0d56513ff"
 SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index c785354695a8b3e528d96f4809a20ca4dd98acd6..667212f1df18944c2cffdf63c8e62bae7c7db598 100644 (file)
@@ -11,14 +11,14 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "5049ec1a05cf7c9ff19c892b42d67f17974d3a96"
-SRCREV_machine_qemuarm64 ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
-SRCREV_machine_qemumips ?= "c01dfca5d22960a5b9e4aa47d9c062ecbded5857"
-SRCREV_machine_qemuppc ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
-SRCREV_machine_qemux86 ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
-SRCREV_machine_qemux86-64 ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
-SRCREV_machine_qemumips64 ?= "b8342b84b3a914651c86f3ae463e4f8c6de36da0"
-SRCREV_machine ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
+SRCREV_machine_qemuarm ?= "a6899b7c294ed25d9d37afde858cdd52f41f86b0"
+SRCREV_machine_qemuarm64 ?= "9ba8c36e9ea7419d06accab5311e7fb0d56513ff"
+SRCREV_machine_qemumips ?= "69936a9614608b7aa893ae78bd69e5cc197816c3"
+SRCREV_machine_qemuppc ?= "9ba8c36e9ea7419d06accab5311e7fb0d56513ff"
+SRCREV_machine_qemux86 ?= "9ba8c36e9ea7419d06accab5311e7fb0d56513ff"
+SRCREV_machine_qemux86-64 ?= "9ba8c36e9ea7419d06accab5311e7fb0d56513ff"
+SRCREV_machine_qemumips64 ?= "f0eb9eabbeafa5eadf66893822ea42d80e04afbd"
+SRCREV_machine ?= "9ba8c36e9ea7419d06accab5311e7fb0d56513ff"
 SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \