]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-libc-headers: delete include/scsi/scsi.h, it's not for userspace
authorJoshua Lock <josh@linux.intel.com>
Fri, 18 Jun 2010 08:44:33 +0000 (09:44 +0100)
committerJoshua Lock <josh@linux.intel.com>
Fri, 18 Jun 2010 09:33:21 +0000 (10:33 +0100)
include/scsi/scsi.h is not userland parsable and research indicates this is
because the header should not be exposed to userspace. Therefore remove it
in the install.

Research done by Tom Rini <tom_rini@mentor.com> in OE commit
91d3d92a626da89dfe13d63e68a90dbafdbaef1d

This has been the case since kernel 2.6.31

Bump glibc and uclibc PR's so that users have sane <scsi/scsi.h>

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/packages/glibc/glibc_2.4.bb
meta/packages/glibc/glibc_2.9.bb
meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb
meta/packages/uclibc/uclibc_0.9.30.1.bb

index 3102c5953cf6230cce5288f65d3031e9453f6546..ad6840e9bf1bf17f1cfd7791a6a4d764ef09a9a8 100644 (file)
@@ -1,6 +1,6 @@
 require glibc.inc
 
-PR = "r13"
+PR = "r14"
 
 # the -isystem in bitbake.conf screws up glibc do_stage
 BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
index eec2ed29e286f2a537dba7d3fb0ec0aef1c09133..15b625b76078d8bf8b551f5ebf0c9cb5f48dac11 100644 (file)
@@ -5,7 +5,7 @@ ARM_INSTRUCTION_SET = "arm"
 PACKAGES_DYNAMIC = "libc6*"
 RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
 
-PR = "r1"
+PR = "r2"
 
 # the -isystem in bitbake.conf screws up glibc do_stage
 BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
index 4a63910e826b515c48333a3db3d4b2856b4e3313..a299f55c293aaac76ba1094fcd1e802f7646e951 100644 (file)
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
 
 INHIBIT_DEFAULT_DEPS = "1"
 DEPENDS += "unifdef-native"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
        file://hayes-gone.patch"
@@ -41,6 +41,8 @@ do_compile () {
 do_install() {
        set_arch
        oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+       # Kernel should not be exporting this header
+       rm -f ${D}${exec_prefix}/include/scsi/scsi.h
 }
 
 BBCLASSEXTEND = "nativesdk"
index 14b59b74e357f118c5cfd031fa82221b78bd1c7d..6bdf153a2aad20fd5aad79d596c89faadd127c0f 100644 (file)
@@ -9,7 +9,7 @@
 UCLIBC_BASE ?= "0.9.30.1"
 
 require uclibc.inc
-PR = "r0"
+PR = "r1"
 
 PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"