]> code.ossystems Code Review - openembedded-core.git/commitdiff
gzip/pigz/expat/image: Simplify gzip-native/pigz-native
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 27 Jan 2017 12:34:40 +0000 (12:34 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 28 Jan 2017 23:31:17 +0000 (23:31 +0000)
With recipe specific sysroots, the gzip-replacement-native dance/class
is obsolete, simplify the code accordingly.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/gzipnative.bbclass [deleted file]
meta/classes/image.bbclass
meta/classes/image_types.bbclass
meta/recipes-core/expat/expat.inc
meta/recipes-extended/gzip/gzip_1.8.bb
meta/recipes-extended/pigz/pigz_2.3.4.bb

diff --git a/meta/classes/gzipnative.bbclass b/meta/classes/gzipnative.bbclass
deleted file mode 100644 (file)
index 326cbbb..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-EXTRANATIVEPATH += "pigz-native gzip-native"
-DEPENDS += "gzip-native"
-
-# tar may get run by do_unpack or do_populate_lic which could call gzip
-do_unpack[depends] += "gzip-native:do_populate_sysroot"
index 71b7ebc958552fa3037f7c221fb6e1aa0de06de7..4d50601bb2f9771e727c0211df3f1504821917d3 100644 (file)
@@ -9,8 +9,6 @@ TOOLCHAIN_TARGET_TASK += "${PACKAGE_INSTALL}"
 TOOLCHAIN_TARGET_TASK_ATTEMPTONLY += "${PACKAGE_INSTALL_ATTEMPTONLY}"
 POPULATE_SDK_POST_TARGET_COMMAND += "rootfs_sysroot_relativelinks; "
 
-inherit gzipnative
-
 LICENSE = "MIT"
 PACKAGES = ""
 DEPENDS += "${MLPREFIX}qemuwrapper-cross depmodwrapper-cross"
index 50545d9fdf0b7711e3a9da849e0886da408e2c18..d3c7326b19bfe84f949f5ab84a06ada2320f5b48 100644 (file)
@@ -359,7 +359,7 @@ CONVERSION_CMD_sha384sum = "sha384sum ${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type}
 CONVERSION_CMD_sha512sum = "sha512sum ${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type} > ${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type}.sha512sum"
 CONVERSION_CMD_bmap = "bmaptool create ${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type} -o ${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type}.bmap"
 CONVERSION_DEPENDS_lzma = "xz-native"
-CONVERSION_DEPENDS_gz = ""
+CONVERSION_DEPENDS_gz = "pigz-native"
 CONVERSION_DEPENDS_bz2 = "pbzip2-native"
 CONVERSION_DEPENDS_xz = "xz-native"
 CONVERSION_DEPENDS_lz4 = "lz4-native"
index fe9d7e74f04a054486a61e67b5c9c1d0afffec00..9fa0ca2eb33b89a9846d21f43ab41b2565a2516b 100644 (file)
@@ -7,12 +7,12 @@ LICENSE = "MIT"
 SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
            file://autotools.patch \
          "
-
-inherit autotools lib_package gzipnative
+inherit autotools lib_package
 
 # This package uses an archive format known to have issue with some
 # versions of gzip
-do_unpack[depends] += "gzip-native:do_populate_sysroot"
+DEPENDS += "pigz-native"
+do_unpack[depends] += "pigz-native:do_populate_sysroot"
 
 do_configure_prepend () {
        rm -f ${S}/conftools/libtool.m4
index a19b96539956edb1f6301a3c608722c381a0861d..11be846b21c99c1cf57f037106399e2a832b862c 100644 (file)
@@ -9,7 +9,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
                     file://gzip.h;beginline=8;endline=20;md5=6e47caaa630e0c8bf9f1bc8d94a8ed0e"
 
 PROVIDES_append_class-native = " gzip-replacement-native"
-NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
 
 BBCLASSEXTEND = "native"
 
index 87b61bfb2997ef31dd7836869a97d51881c46560..53c56c59479c4a21f30a828608314c066ee89401 100644 (file)
@@ -7,7 +7,5 @@ SRC_URI = "https://github.com/madler/pigz/archive/v${PV}.tar.gz"
 SRC_URI[md5sum] = "c109057050b15edf3eb9bb4d0805235e"
 SRC_URI[sha256sum] = "763f2fdb203aa0b7b640e63385e38e5dd4e5aaa041bc8e42aa96f2ef156b06e8"
 
-NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
-
 BBCLASSEXTEND = "native nativesdk"