]> code.ossystems Code Review - openembedded-core.git/commitdiff
autotools.bbclass: Replace "grep ... >/dev/null" with "grep -q"
authorRobert P. J. Day <rpjday@crashcourse.ca>
Sun, 26 Mar 2017 10:24:07 +0000 (06:24 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 26 Mar 2017 23:07:36 +0000 (00:07 +0100)
For aesthetic style reasons, use "grep -q" instead of ">/dev/null".

Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/autotools.bbclass

index d49473440e672992a2824ec3907c86cd04136a21..ac04a07cb535130074217c614817b51717971ef1 100644 (file)
@@ -193,14 +193,14 @@ autotools_do_configure() {
                else
                        CONFIGURE_AC=configure.ac
                fi
-               if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
-                       if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
+               if grep -q "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC; then
+                       if grep -q "sed.*POTFILES" $CONFIGURE_AC; then
                                : do nothing -- we still have an old unmodified configure.ac
                        else
                                bbnote Executing glib-gettextize --force --copy
                                echo "no" | glib-gettextize --force --copy
                        fi
-               elif grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+               elif grep -q "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC; then
                        # We'd call gettextize here if it wasn't so broken...
                        cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
                        if [ -d ${S}/po/ ]; then
@@ -212,7 +212,7 @@ autotools_do_configure() {
                        PRUNE_M4="$PRUNE_M4 gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4"
                fi
                mkdir -p m4
-               if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+               if grep -q "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC; then
                        if ! echo "${DEPENDS}" | grep -q intltool-native; then
                                bbwarn "Missing DEPENDS on intltool-native"
                        fi