]> code.ossystems Code Review - openembedded-core.git/commitdiff
openjade-native: work around bug exposed by GCC 6
authorDan McGregor <danismostlikely@gmail.com>
Tue, 10 May 2016 16:04:47 +0000 (10:04 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 14 May 2016 06:26:41 +0000 (07:26 +0100)
From: Daniel McGregor <daniel.mcgregor@vecima.com>

Simply turn off the optimzation that is causing this breakage. I had
originally used -fno-lifetime-dse, but -fno-tree-dse works at least
going back as far as gcc 4.8.

This isn't a real fix, but it allows openjade to work enough to complete
a build.

Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/openjade/openjade-native_1.3.2.bb

index bc250080f137b0f27fb272dea922b8d4176a9bd3..afcb8ca13a4a65461ad6cef5aa66811ea1972e55 100644 (file)
@@ -44,6 +44,7 @@ CONFIGUREOPTS := "${@d.getVar('CONFIGUREOPTS', True).replace('--datadir=${datadi
 oe_runconf[vardepsexclude] += "CONFIGUREOPTS"
 
 CFLAGS =+ "-I${S}/include"
+CXXFLAGS += "-fno-tree-dse"
 
 SSTATEPOSTINSTFUNCS += "openjade_sstate_postinst"
 SYSROOT_PREPROCESS_FUNCS += "openjade_sysroot_preprocess"