]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: Change execution order between checkroot and modutils
authorDiego Sueiro <diego.sueiro@arm.com>
Thu, 3 Dec 2020 11:18:14 +0000 (11:18 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 6 Dec 2020 23:16:50 +0000 (23:16 +0000)
When '/' is first mounted as read-only, we want to have the checkroot.sh
initscript (which then remounts '/' as rw if allowed) running before the
modutils.sh.
This is because modutils.sh initscript might need to run depmod depending on
the status of the modules.dep file to update it and the '/' needs to be
writable.

Signed-off-by: Diego Sueiro <diego.sueiro@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/initscripts/initscripts_1.0.bb
meta/recipes-kernel/modutils-initscripts/modutils-initscripts.bb

index 32c527799ead2838fa97d92e7fb8cd367395db62..5e994f2b7fd0f63c6374a9d38b3612935d848b66 100644 (file)
@@ -136,7 +136,7 @@ do_install () {
        update-rc.d -r ${D} halt start 90 0 .
        update-rc.d -r ${D} save-rtc.sh start 25 0 6 .
        update-rc.d -r ${D} banner.sh start 02 S .
-       update-rc.d -r ${D} checkroot.sh start 06 S .
+       update-rc.d -r ${D} checkroot.sh start 05 S .
        update-rc.d -r ${D} mountall.sh start 03 S .
        update-rc.d -r ${D} hostname.sh start 39 S .
        update-rc.d -r ${D} mountnfs.sh start 15 2 3 4 5 .
index 881b7db92e5138a14623b3464f3e685748c4d61c..97b4ddb88b6b32b0fd02988d3884e8ae968ae905 100644 (file)
@@ -10,7 +10,7 @@ PR = "r7"
 S = "${WORKDIR}"
 
 INITSCRIPT_NAME = "modutils.sh"
-INITSCRIPT_PARAMS = "start 05 S ."
+INITSCRIPT_PARAMS = "start 06 S ."
 
 inherit update-rc.d