]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdk-pixbuf: remove native loader cache generation, use the class
authorRoss Burton <ross.burton@intel.com>
Fri, 17 May 2013 08:54:39 +0000 (09:54 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 24 May 2013 13:06:58 +0000 (14:06 +0100)
We assumed that the only relevant gdk-pixbuf loaders in the native environment
were the ones in gdk-pixbuf itself, as the icon cache is only for PNG files.
However, glib-compile-resources can transform SVG files to raw image data, and
done natively this requires the SVG loader to be registered.  The current
implementation relies on this assumption by generating the cache based on the
staging directory during install, so if gdk-pixbuf-native is re-installed to the
sysroot after librsvg-native it will overwrite the loader cache.

So, remove the code in do_install that updated the cache, and rely on the new
logic in pixbufcache.bbclass that updates the cache when it's installed into the
sysroot itself.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.26.5.bb

index b35f7c666a8c263ac8342b151cf53400463f4d78..b85bbaf58c9e27c4ea7b95fc54731597e3b676f9 100644 (file)
@@ -69,9 +69,6 @@ python populate_packages_prepend () {
 }
 
 do_install_append_class-native() {
-#Use wrapper script rather than binary as required libtool library is not installed now
-       GDK_PIXBUF_MODULEDIR=${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders ${B}/gdk-pixbuf/gdk-pixbuf-query-loaders > ${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
-       sed -i -e 's#${D}##g' ${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
        find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
 
        create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \