]> code.ossystems Code Review - openembedded-core.git/commitdiff
ca-certificates: clean up before do_compile()
authorAndreas Oberritter <obi@opendreambox.org>
Mon, 23 Mar 2015 15:36:50 +0000 (16:36 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Mar 2015 17:52:40 +0000 (17:52 +0000)
Otherwise the script which converts mozilla certificates extracts
each certificate twice.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/ca-certificates/ca-certificates_20141019.bb

index e5a482138f9388ec93aca3d232ff440933bbe2e1..421b87ec02283f9d6780bff599e81ca673985ddb 100644 (file)
@@ -29,6 +29,10 @@ EXTRA_OEMAKE = "\
     'SBINDIR=${sbindir}' \
 "
 
+do_compile_prepend() {
+    oe_runmake clean
+}
+
 do_install () {
     install -d ${D}${datadir}/ca-certificates \
                ${D}${sysconfdir}/ssl/certs \