]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-omap-2.6.24.7: Fix compile failure
authorRichard Purdie <richard@openedhand.com>
Wed, 8 Oct 2008 09:55:48 +0000 (09:55 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 8 Oct 2008 09:55:48 +0000 (09:55 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5449 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/linux/linux-omap-2.6.24.7/fixes2.patch [new file with mode: 0644]
meta/packages/linux/linux-omap_2.6.24.7.bb

diff --git a/meta/packages/linux/linux-omap-2.6.24.7/fixes2.patch b/meta/packages/linux/linux-omap-2.6.24.7/fixes2.patch
new file mode 100644 (file)
index 0000000..362368a
--- /dev/null
@@ -0,0 +1,34 @@
+Index: linux-2.6.24/drivers/video/omap/omap_disp_out.c
+===================================================================
+--- linux-2.6.24.orig/drivers/video/omap/omap_disp_out.c       2008-10-08 10:53:04.000000000 +0100
++++ linux-2.6.24/drivers/video/omap/omap_disp_out.c    2008-10-08 10:53:57.000000000 +0100
+@@ -1020,6 +1020,7 @@
+       else
+               return -EINVAL;
++#ifdef CONFIG_OMAP2_TV
+       if (out_dev == OMAP2_OUTPUT_TV) {
+                       if (tv_in_use == 0) {
+                               h4_i2c_tvout_on(NULL);
+@@ -1027,6 +1028,7 @@
+                               tv_in_use = 1;  
+                       }
+       }
++#endif
+       if(omap2_disp_get_output_dev(layer) == out_dev)
+               return count;
+@@ -1050,11 +1052,13 @@
+                                       (omap2_disp_get_output_dev(OMAP2_VIDEO1) == OMAP2_OUTPUT_LCD) &&
+                                       (omap2_disp_get_output_dev(OMAP2_VIDEO2) == OMAP2_OUTPUT_LCD))
+       {               
++#ifdef CONFIG_OMAP2_TV
+                       if (tv_in_use != 0) {
+                                       omap2_disp_disable_output_dev(OMAP2_OUTPUT_TV);
+                                       h4_i2c_tvout_off(NULL);
+                                       tv_in_use = 0;  
+                       }
++#endif
+       }
+                        
+       return count;
index 5baa320e1c1092030353d8213f04a7e549be7c46..e04e5677fb437421eacefd300061b290f0d02849 100644 (file)
@@ -1,6 +1,6 @@
 require linux-omap.inc
 
-PR = "r2"
+PR = "r3"
 
 COMPATIBLE_MACHINE = "omap-3430ldp|omap-3430sdp"
 DEFAULT_PREFERENCE = "1"
@@ -14,6 +14,7 @@ SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
          http://kernel.org/pub/linux/kernel/v2.6/patch-2.6.24.7.bz2;patch=1 \
          file://linux-2.6.24.7-ldp-v1.4.patch.gz;patch=1 \
          file://fixes.patch;patch=1 \
+         file://fixes2.patch;patch=1 \
          file://module_fix.patch;patch=1 \
          file://defconfig-${MACHINE}"