]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-minimal: Add 4M extra space when using systemd
authorKhem Raj <raj.khem@gmail.com>
Sat, 15 Aug 2015 22:02:16 +0000 (15:02 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 30 Aug 2015 11:34:16 +0000 (12:34 +0100)
qemu images fail to rebuild the hwdb due to no space letf on device

 systemd-hwdb-update.service - Rebuild Hardware Database
   Loaded: loaded (/lib/systemd/system/systemd-hwdb-update.service;
   static; vendor preset: enabled)
      Active: failed (Result: exit-code) since Sat 2015-08-15 21:39:28
      UTC; 28s ago
      Docs: man:hwdb(7)
            man:systemd-hwdb(8)
        Process: 92 ExecStart=/bin/systemd-hwdb update
(code=exited, status=1/FAILURE)
 Main PID: 92 (code=exited, status=1/FAILURE)

 Aug 15 21:39:28 qemux86 systemd-hwdb[92]:
 Failure writing database //etc/udev/hwdb.bin:
 No space left on device
 Aug 15 21:39:28 qemux86 systemd[1]:
 systemd-hwdb-update.service: Main process
 exited, code=exited, status=1/FAILURE
 Aug 15 21:39:28 qemux86 systemd[1]: Failed to
 start Rebuild Hardware Database.

(From OE-Core rev: 4086c539d47bc837e775972016e1844a3676c8e7)

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/images/core-image-minimal.bb

index 9716274c34f4609fc3a330f493f3cf6635545c9f..8dd77b3472e3abe77c28e9f7d53ddb1525d172e2 100644 (file)
@@ -9,4 +9,4 @@ LICENSE = "MIT"
 inherit core-image
 
 IMAGE_ROOTFS_SIZE ?= "8192"
-
+IMAGE_ROOTFS_EXTRA_SPACE_append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"