]> code.ossystems Code Review - openembedded-core.git/commitdiff
cmake-native: disable check for acl.h
authorChen Qi <Qi.Chen@windriver.com>
Mon, 5 Jan 2015 03:04:07 +0000 (11:04 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Jan 2015 23:33:09 +0000 (23:33 +0000)
We build cmake-native without acl support. However, the acl.h header
is still being checked which would sometimes cause the following error
during do_compile:

     archive_read_disk_entry_from_file.c:38:21: fatal error: sys/acl.h: No such file or directory
     |  #include <sys/acl.h>
     |                      ^
     | compilation terminated.

This happens when the sysroot parts of acl-native is removed between
do_configure and do_compile tasks of cmake-native.

To reproduce the problem manually, execute the following command:

bitbake cmake-native -c cleansstate && bitbake acl-native -c cleansstate && \
bitbake acl-native && bitbake cmake-native -c configure && \
bitbake acl-native -c cleansstate && bitbake cmake-native -c compile

This patch fixes the above problem by explicitly disable the checking for
acl.h header file.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb

index cd6b1d8845726cbdf04eccdcae16d429fa88e601..e40dfdd2d82c7ec56b8106718a037cd81a327041 100644 (file)
@@ -15,4 +15,5 @@ SRC_URI[sha256sum] = "8c6574e9afabcb9fc66f463bb1f2f051958d86c85c37fccf067eb1a44a
 CMAKE_EXTRACONF = "\
     -DBUILD_CursesDialog=0 \
     -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+    -DHAVE_SYS_ACL_H=0 \
 "