]> code.ossystems Code Review - openembedded-core.git/commitdiff
libassuan: use package specific licensing
authorAndre McCurdy <armccurdy@gmail.com>
Fri, 1 Apr 2016 05:00:58 +0000 (22:00 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 1 Apr 2016 14:03:55 +0000 (15:03 +0100)
 - The main libassuan.so library is LGPLv2.1+
 - Test apps (in tests sub directory) and documentation are GPLv3+
 - Windows CE specific binaries (gpgcedev.dll and gpgcemgr) are GPLv3+

When building the current OE recipe, the test apps are compiled but
not installed. The Windows CE specific binaries are not compiled.

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libassuan/libassuan_2.4.2.bb

index 57eab38570f9b8105320c389259d365a0d02c555..f376d631ed445105f5df14af2f49d0d48c636283 100644 (file)
@@ -2,7 +2,9 @@ SUMMARY = "IPC library used by GnuPG and GPGME"
 HOMEPAGE = "http://www.gnupg.org/related_software/libassuan/"
 BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
 
-LICENSE = "GPLv3 & LGPLv2.1+"
+LICENSE = "GPLv3+ & LGPLv2.1+"
+LICENSE_${PN} = "LGPLv2.1+"
+LICENSE_${PN}-doc = "GPLv3+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
                     file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
                     file://src/assuan.c;endline=20;md5=0f465544183405055ec179869fc5b5ba \
@@ -21,7 +23,7 @@ BINCONFIG = "${bindir}/libassuan-config"
 inherit autotools texinfo binconfig-disabled pkgconfig
 
 do_configure_prepend () {
-       # Else these could be used in prefernce to those in aclocal-copy
+       # Else these could be used in preference to those in aclocal-copy
        rm -f ${S}/m4/*.m4
 }