]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo: Revert msg cache changes
authorMark Hatle <mark.hatle@windriver.com>
Tue, 25 Jan 2011 01:23:14 +0000 (19:23 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 25 Jan 2011 12:25:45 +0000 (12:25 +0000)
The message cache code in pseudo seems to be causing problems.  So we have
finally decided to revert that optimization.

(The revert is in the upstream pseudo.)

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch [deleted file]
meta/recipes-devtools/pseudo/pseudo_git.bb

index 8d98eef0f634c072830a9ddf8be15817b706569d..6de6fd8ac4a77dfb3183e88a5654acab2f589b63 100644 (file)
@@ -150,7 +150,7 @@ PRELINKSRCREV ??= "909470ee441237563d6236c505cb2d02ddc48704"
 SRCREV_pn-prelink ??= "${PRELINKSRCREV}"
 SRCREV_pn-prelink-native ??= "${PRELINKSRCREV}"
 SRCREV_pn-psplash ??= "424"
-PSEUDOSRCREV ??= "a1b25a64d8dd012bc8adcac1e1e09b6291c877ad"
+PSEUDOSRCREV ??= "bcb42d80c0817da5479ab9c4f2cd8c4727e98ef8"
 SRCREV_pn-pseudo ??= "${PSEUDOSRCREV}"
 SRCREV_pn-pseudo-native ??= "${PSEUDOSRCREV}"
 SRCREV_pn-pseudo-nativesdk ??= "${PSEUDOSRCREV}"
diff --git a/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch b/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch
deleted file mode 100644 (file)
index a73ed64..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-The cached data values were being collected when an OP_EXEC call was made.
-This is incorrect as the values are only for logging purposes.  It's believed
-this caused an occasional crash in certain instances.
-
-Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-
-diff --git a/pseudo.c b/pseudo.c
-index efee436..62f28f3 100644
---- a/pseudo.c
-+++ b/pseudo.c
-@@ -1021,7 +1021,8 @@ pseudo_op(pseudo_msg_t *msg, const char *program, const char *tag) {
-       if (msg->op != OP_MAY_UNLINK &&
-           msg->op != OP_DID_UNLINK &&
-           msg->op != OP_CANCEL_UNLINK &&
--          msg->op != OP_UNLINK) {
-+          msg->op != OP_UNLINK &&
-+          msg->op != OP_EXEC ) {
-               cache_msg = *msg;
-               if (path_by_ino) {
index 6645033c3eeb852068750defc4a976dccd43789a..4e94df7e8c4f7362e7dc2b15e5c3742d44bfb3f4 100644 (file)
@@ -6,11 +6,10 @@ LICENSE = "LGPL2.1"
 DEPENDS = "sqlite3"
 
 PV = "0.0+git${SRCPV}"
-PR = "r16"
+PR = "r17"
 
 SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
            file://static_sqlite.patch \
-          file://pseudo-exec-crash.patch \
          "
 
 FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo"