]> code.ossystems Code Review - openembedded-core.git/commitdiff
zip: Remove QA warnings: No GNU_HASH in the elf binary
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>
Wed, 5 Dec 2012 15:02:10 +0000 (20:02 +0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Dec 2012 12:30:37 +0000 (12:30 +0000)
Update the LFLAGS1 in the Makefile to remove warnings:
QA Issue: No GNU_HASH in the elf binary

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/zip/zip.inc

index a3bbc934e082761b51ce3a918d01de9be93c1774..265d9a8adb3fd5f04659b5860e5fee62c4e6ff0e 100644 (file)
@@ -12,6 +12,8 @@ EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
                'BINFLAGS=0755' 'INSTALL_D=install -d'"
 
 do_compile() {
+       oe_runmake -f unix/Makefile flags
+       sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
        oe_runmake -f unix/Makefile generic
 }