]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: Fix python code quoting issues
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 14 Jan 2019 22:21:37 +0000 (22:21 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 14 Jan 2019 23:04:03 +0000 (23:04 +0000)
python 3.8 will be stricter about python quoting. Fix up several misquoted
expressions and fix Deprecation warnings like:

Var <do_compile>:1: DeprecationWarning: invalid escape sequence \$

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/cml1.bbclass
meta/classes/gtk-doc.bbclass
meta/classes/populate_sdk_base.bbclass
meta/recipes-gnome/gobject-introspection/gobject-introspection_1.58.2.bb

index 926747f2ba615fb2af9f3eaaa558188cb90f7b98..7f6df4011bc0c924438cce4abdb3921ddff6b6c4 100644 (file)
@@ -26,7 +26,7 @@ python do_menuconfig() {
     except OSError:
         mtime = 0
 
-    oe_terminal("${SHELL} -c \"make %s; if [ \$? -ne 0 ]; then echo 'Command failed.'; printf 'Press any key to continue... '; read r; fi\"" % d.getVar('KCONFIG_CONFIG_COMMAND'),
+    oe_terminal("${SHELL} -c \"make %s; if [ \\$? -ne 0 ]; then echo 'Command failed.'; printf 'Press any key to continue... '; read r; fi\"" % d.getVar('KCONFIG_CONFIG_COMMAND'),
                 d.getVar('PN') + ' Configuration', d)
 
     # FIXME this check can be removed when the minimum bitbake version has been bumped
index b4f6754906aa9ba04482b5f80ad60afd10e494de..bedb36ec8b7363fe3953bdf17c17176f9865a901 100644 (file)
@@ -41,7 +41,7 @@ do_compile_prepend_class-target () {
     if [ ${GTKDOC_ENABLED} = True ]; then
         # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it
         # can run target helper binaries through that.
-        qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\$GIR_EXTRA_LIBS_PATH','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
+        qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
         cat > ${B}/gtkdoc-qemuwrapper << EOF
 #!/bin/sh
 # Use a modules directory which doesn't exist so we don't load random things
index 677ba3cf12fd737533931ed4f8b74370edc0ef50..a4afc61c465e98c1b8c06bc673526493eaa6a251 100644 (file)
@@ -257,7 +257,7 @@ EOF
                -e 's#@SDKEXTPATH@#${SDKEXTPATH}#g' \
                -e 's#@OLDEST_KERNEL@#${SDK_OLDEST_KERNEL}#g' \
                -e 's#@REAL_MULTIMACH_TARGET_SYS@#${REAL_MULTIMACH_TARGET_SYS}#g' \
-               -e 's#@SDK_TITLE@#${@d.getVar("SDK_TITLE").replace('&', '\&')}#g' \
+               -e 's#@SDK_TITLE@#${@d.getVar("SDK_TITLE").replace('&', '\\&')}#g' \
                -e 's#@SDK_VERSION@#${SDK_VERSION}#g' \
                -e '/@SDK_PRE_INSTALL_COMMAND@/d' \
                -e '/@SDK_POST_INSTALL_COMMAND@/d' \
index 242899accc44041044dc0474af5293bc2f1b8f18..d00f3bd34413d48949493b2a61c61e482a6523c0 100644 (file)
@@ -76,7 +76,7 @@ do_configure_prepend_class-native() {
 do_configure_prepend_class-target() {
         # Write out a qemu wrapper that will be given to gi-scanner so that it
         # can run target helper binaries through that.
-        qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\$GIR_EXTRA_LIBS_PATH','.libs','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
+        qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','.libs','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
         cat > ${B}/g-ir-scanner-qemuwrapper << EOF
 #!/bin/sh
 # Use a modules directory which doesn't exist so we don't load random things