]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add libnss-mdns (for avahi)
authorRichard Purdie <richard@openedhand.com>
Tue, 9 May 2006 17:45:29 +0000 (17:45 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 9 May 2006 17:45:29 +0000 (17:45 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@385 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/libnss-mdns/files/alignment-fix.patch [new file with mode: 0644]
openembedded/packages/libnss-mdns/libnss-mdns_0.7.bb [new file with mode: 0644]

diff --git a/openembedded/packages/libnss-mdns/files/alignment-fix.patch b/openembedded/packages/libnss-mdns/files/alignment-fix.patch
new file mode 100644 (file)
index 0000000..11d4655
--- /dev/null
@@ -0,0 +1,11 @@
+--- nss-mdns-0.6/src/nss.c.orig        2005-09-25 17:27:51 +0200
++++ nss-mdns-0.6/src/nss.c     2005-09-25 17:28:55 +0200
+@@ -456,6 +456,8 @@
+     result->h_addrtype = af;
+     result->h_length = address_length;
+     
++    idx+=(sizeof(char*)-idx%sizeof(char*)); /* Align on 32 bit boundary */
++    
+     /* Check if there's enough space for the addresses */
+     if (buflen < idx+u.data_len+sizeof(char*)*(u.count+1)) {
+         *errnop = ERANGE;
diff --git a/openembedded/packages/libnss-mdns/libnss-mdns_0.7.bb b/openembedded/packages/libnss-mdns/libnss-mdns_0.7.bb
new file mode 100644 (file)
index 0000000..306adb0
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "NSS module for Multicast DNS name resolution"
+HOMEPAGE = "http://0pointer.de/lennart/projects/nss-mdns/"
+LICENSE = "GPL"
+SECTION = "libs"
+PRIORITY = "optional"
+
+RRECOMMENDS_${PN} = "avahi-daemon zeroconf"
+PR = "r0"
+
+EXTRA_OECONF = "--libdir=/lib"
+S = "${WORKDIR}/nss-mdns-${PV}"
+
+SRC_URI = "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-${PV}.tar.gz"
+
+inherit autotools
+
+pkg_postinst () {
+       cat /etc/nsswitch.conf | grep "hosts:\s*files dns$" > /dev/null && {
+               cat /etc/nsswitch.conf | sed 's/hosts:\s*files dns/& mdns4/' > /tmp/nsswitch.conf
+               mv /tmp/nsswitch.conf /etc/nsswitch.conf
+       }
+}
+
+pkg_prerm () {
+       cat /etc/nsswitch.conf | grep "hosts:\s*files dns mdns$" > /dev/null && {
+               cat /etc/nsswitch.conf | sed 's/\(hosts:\s*files dns\) mdns4*/\1/' > /tmp/nsswitch.conf
+               mv /tmp/nsswitch.conf /etc/nsswitch.conf
+       }
+}