]> code.ossystems Code Review - openembedded-core.git/commitdiff
ltp: Fix format security warnings with gcc10
authorKhem Raj <raj.khem@gmail.com>
Wed, 20 May 2020 05:26:34 +0000 (22:26 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 May 2020 09:49:12 +0000 (10:49 +0100)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Petr Vorel <petr.vorel@gmail.com>
Cc: Daniel Díaz <daniel.diaz@linaro.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/ltp/ltp/0001-ptrace01-Fix-missing-format-string.patch [new file with mode: 0644]
meta/recipes-extended/ltp/ltp_20200515.bb

diff --git a/meta/recipes-extended/ltp/ltp/0001-ptrace01-Fix-missing-format-string.patch b/meta/recipes-extended/ltp/ltp/0001-ptrace01-Fix-missing-format-string.patch
new file mode 100644 (file)
index 0000000..27b890e
--- /dev/null
@@ -0,0 +1,33 @@
+From adb9587466a493fdd9d4410f1b8b130ebca06daa Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 19 May 2020 22:21:23 -0700
+Subject: [PATCH] ptrace01: Fix missing format string
+
+Fixes
+| ptrace01.c:89:2: error: format string is not a string literal
+(potentially insecure) [-Werror,-Wformat-security]
+|         tst_res(TINFO, tc->message);
+|         ^              ~~~~~~~~~~~
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Backport [58424835952641f4fd60c0ae3ab6c64decca3f8a]
+---
+ testcases/kernel/syscalls/ptrace/ptrace01.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/testcases/kernel/syscalls/ptrace/ptrace01.c b/testcases/kernel/syscalls/ptrace/ptrace01.c
+index 87a99e4150..9071bbabaf 100644
+--- a/testcases/kernel/syscalls/ptrace/ptrace01.c
++++ b/testcases/kernel/syscalls/ptrace/ptrace01.c
+@@ -86,7 +86,7 @@ static void run(unsigned int i)
+       got_signal = 0;
+-      tst_res(TINFO, tc->message);
++      tst_res(TINFO, "%s", tc->message);
+       if (tc->handler == 1) {
+               parent_act.sa_handler = parent_handler;
+-- 
+2.26.2
+
index 37bad537661292b6261eb4ab0d1654a8e3804e42..e82f6b33a1c74613e045c0a351a2ce1e422209ac 100644 (file)
@@ -34,6 +34,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
            file://0004-guard-mallocopt-with-__GLIBC__.patch \
            file://0007-Fix-test_proc_kill-hanging.patch \
            file://0001-Add-more-musl-exclusions.patch \
+           file://0001-ptrace01-Fix-missing-format-string.patch \
            "
 
 S = "${WORKDIR}/git"