]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipes: Replace gconf-dbus with gconf
authorKhem Raj <raj.khem@gmail.com>
Wed, 27 Apr 2011 16:22:05 +0000 (09:22 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 May 2011 08:51:40 +0000 (09:51 +0100)
Some distributions e.g. angstrom do not support gconf-dbus
anymore since its now provided by gconf and in oe-core we
have PREFERRED_PROVIDER_gconf tunable, here we replace all
dependencies on gconf-dbus with gconf, which should work
in both cases where poky defines
PREFERRED_PROVIDER-gconf = "gconf-dbus" and for angstrom
it is simply gconf

Without this meta-toolchain-sdk ends up with conflicts in
runqueue and does not build

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta-demoapps/recipes-gnome/gnome/libgnomekbd_2.26.0.bb
meta/recipes-gnome/gnome/gnome-desktop.inc
meta/recipes-gnome/gthumb/gthumb_2.12.2.bb
meta/recipes-gnome/tasks/task-sdk-gmae.inc
meta/recipes-support/libproxy/libproxy_0.4.6.bb

index f2e4ec533ec9bc106c2fb534e39a6b8a326d81aa..68e4eeef49d1b54693fa88068ab37fdf3aa99605 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "GNOME keyboard library"
 LICENSE = "LGPL"
 
-DEPENDS = "gconf-dbus dbus libxklavier gtk+"
+DEPENDS = "gconf dbus libxklavier gtk+"
 
 inherit gnome
 
index 123f82da73270d7e7bcc71f04504de21f549cd04..336b87f248f811ebce982e05f786220ee7b4b4fa 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "GNOME library for reading .desktop files"
 SECTION = "x11/gnome"
 LICENSE = "GPLv2 & LGPLv2"
-DEPENDS = "gconf-dbus libxrandr virtual/libx11 gtk+ glib-2.0 gnome-doc-utils"
+DEPENDS = "gconf libxrandr virtual/libx11 gtk+ glib-2.0 gnome-doc-utils"
 
 EXTRA_OECONF = "--disable-scrollkeeper --disable-desktop-docs"
 
index 0b3bd1a67560863ce51c35a1640e29c1e08ac549..258f2d5759e172fc941c30cb2e8797d793c5899a 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "gThumb is an image viewer and browser for the GNOME Desktop"
 SECTION = "x11/gnome"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-DEPENDS = "glib-2.0 gtk+ libxml2 gnome-doc-utils libunique gconf-dbus libpng gstreamer jpeg tiff gst-plugins-base"
+DEPENDS = "glib-2.0 gtk+ libxml2 gnome-doc-utils libunique gconf libpng gstreamer jpeg tiff gst-plugins-base"
 PR = "r0"
 
 EXTRA_OECONF = "--disable-gnome-keyring --disable-libsoup --disable-exiv2 --disable-clutter"
index 586d76fd73aa6fe829b831d150f9bd1f3b063359..b24fc9eb913655b195c942f39333b906fcc828b9 100644 (file)
@@ -4,7 +4,7 @@ SDK-GMAE = " \
     gtk+-dev \
     gstreamer-dev \
     bluez4-dev \
-    gconf-dbus-dev \
+    gconf-dev \
     avahi-dev \
     telepathy-glib-dev \
     eds-dbus-dev \
index 255cd5bfa4813d9694b97915b3acdaa7c7f98b76..2e1806540fc0ea374269680c7f1f37e7d44269d2 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7d7044444a7b1b116e8783edcdb44ff4 \
                     file://utils/proxy.c;beginline=1;endline=18;md5=55152a1006d7dafbef32baf9c30a99c0"
 
 
-DEPENDS = "virtual/libx11 xmu gconf-dbus"
+DEPENDS = "virtual/libx11 xmu gconf"
 
 SRC_URI = "http://libproxy.googlecode.com/files/libproxy-${PV}.tar.gz"