]> code.ossystems Code Review - openembedded-core.git/commitdiff
guile: cleanup buildpaths and add RDEPENDS on pkgconfig
authorJackie Huang <jackie.huang@windriver.com>
Wed, 23 Sep 2015 08:41:57 +0000 (16:41 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 23 Sep 2015 21:07:18 +0000 (22:07 +0100)
* fix the path for "define %pkg-config-program" in guile-config
* clean the --sysroot in guile-snarf
* add RDEPENDS on pkgconfig

Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/guile/guile_2.0.11.bb

index 486969422c02e469dc8f9a3474375fd7a4722971..f4557409a1f194024e9f54d3cd4ee14f59f17064 100644 (file)
@@ -39,7 +39,11 @@ DEPENDS = "libunistring bdwgc gmp libtool libffi ncurses readline"
 # add guile-native only to the target recipe's DEPENDS
 DEPENDS_append_class-target = " guile-native libatomic-ops"
 
-RDEPENDS_${PN}_append_libc-glibc_class-target = "glibc-gconv-iso8859-1"
+# The comment of the script guile-config said it has been deprecated but we should
+# at least add the required dependency to make it work since we still provide the script.
+RDEPENDS_${PN} = "pkgconfig"
+
+RDEPENDS_${PN}_append_libc-glibc_class-target = " glibc-gconv-iso8859-1"
 
 EXTRA_OECONF += "${@['--without-libltdl-prefix --without-libgmp-prefix --without-libreadline-prefix', ''][bb.data.inherits_class('native',d)]}"
 
@@ -77,6 +81,12 @@ do_install_append_class-native() {
                GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
 }
 
+do_install_append_class-target() {
+       # cleanup buildpaths in scripts
+       sed -i -e 's:${STAGING_DIR_NATIVE}::' ${D}/usr/bin/guile-config
+       sed -i -e 's:${STAGING_DIR_HOST}::' ${D}/usr/bin/guile-snarf
+}
+
 SYSROOT_PREPROCESS_FUNCS = "guile_cross_config"
 
 guile_cross_config() {