]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.12: backport bugfixes for x86
authorBruce Ashfield <bruce.ashfield@windriver.com>
Wed, 14 Mar 2018 15:10:29 +0000 (11:10 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 15 Mar 2018 10:38:49 +0000 (03:38 -0700)
Integrating the following commits:

  60b649971940 x86/hibernate/64: Mask off CR3's PCID bits in the saved CR3
  cec3c008ec8f drm/i915/cfl: Coffee Lake works on Kaby Lake PCH.
  073873cb152c brd: remove unused brd_mutex
  912c53b1b346 audit: fix memleak in auditd_send_unicast_skb.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
meta/recipes-kernel/linux/linux-yocto_4.12.bb

index a100f7d4a9f98443186a82487c54f56b9825cbb8..ad0981296f5a04345feca36345d9cbaf53f26db4 100644 (file)
@@ -11,7 +11,7 @@ python () {
         raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "b103a20d4b507ede60adc8478dade56a4bdaffad"
+SRCREV_machine ?= "da775aa9aab41e8a2b4e9b44ffe268446c51759f"
 SRCREV_meta ?= "4f825eeb783a279216ee45ed3b9a63dd6837f7d7"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
index c306db292b2eb4fed437fdb7b75e824bbae2cbb6..0bbd8e28db86fbe94f9af71ddcc4a81e44cd5ff6 100644 (file)
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.12.20"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "cec3c008ec8f7acdb01b95fceb1ef7dff35d1877"
+SRCREV_machine ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
 SRCREV_meta ?= "4f825eeb783a279216ee45ed3b9a63dd6837f7d7"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 78a291acf0a607b37f2691da7f91280f121605ec..fabf0f554bbf496e4964aa6fe85efb4b4a1150c4 100644 (file)
@@ -11,14 +11,14 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "4fb13c0d7254fe9753bebdfcfe47fd1ba4487386"
-SRCREV_machine_qemuarm64 ?= "cec3c008ec8f7acdb01b95fceb1ef7dff35d1877"
-SRCREV_machine_qemumips ?= "9eb1f72874eeadb1f17e59faaca331971d522e12"
-SRCREV_machine_qemuppc ?= "cec3c008ec8f7acdb01b95fceb1ef7dff35d1877"
-SRCREV_machine_qemux86 ?= "cec3c008ec8f7acdb01b95fceb1ef7dff35d1877"
-SRCREV_machine_qemux86-64 ?= "cec3c008ec8f7acdb01b95fceb1ef7dff35d1877"
-SRCREV_machine_qemumips64 ?= "710cc1cb7ba1384b9b0f43fc811a18a7c5a4e03f"
-SRCREV_machine ?= "cec3c008ec8f7acdb01b95fceb1ef7dff35d1877"
+SRCREV_machine_qemuarm ?= "42cf4d6a1bc84b90681cb82ad95c129387d76b4b"
+SRCREV_machine_qemuarm64 ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
+SRCREV_machine_qemumips ?= "571315a5526b9e22262cf99bae7c0dd6e5bd204c"
+SRCREV_machine_qemuppc ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
+SRCREV_machine_qemux86 ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
+SRCREV_machine_qemux86-64 ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
+SRCREV_machine_qemumips64 ?= "e7889ba18f060368d4ab35e70b076728d73ba622"
+SRCREV_machine ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
 SRCREV_meta ?= "4f825eeb783a279216ee45ed3b9a63dd6837f7d7"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \