]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdb: add PACKAGECONFIG for babeltrace
authorChen Qi <Qi.Chen@windriver.com>
Tue, 13 May 2014 02:54:26 +0000 (10:54 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 May 2014 18:24:03 +0000 (19:24 +0100)
Add PACKAGECONFIG for 'babeltrace' so that we don't have the implicit
dependency which might lead to problems when building images.

As an example of showing what problem we might have without this patch,
see the following steps which would lead to a failure.
1. IMAGE_INSTALL_append = " gdb"
2. bitbake babeltrace
3. bitbake gdb
4. bitbake babeltrace -ccleansstate
5. bitbake core-image-minimal

The rootfs process would fail with the following error message.
error: Can't install gdb-7.7-r0@i586: no package provides babeltrace >= 1.2.1+git0+66c2a20b43

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gdb/gdb_7.7.bb

index c7ca26b9c1ad71afd4de3a573bd33afe269379ad..1abc9d8e76e1552c1ff6dc08433812cb650b6a0b 100644 (file)
@@ -5,6 +5,7 @@ inherit python-dir
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
+PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
 
 do_configure_prepend() {
        if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then