]> code.ossystems Code Review - openembedded-core.git/commitdiff
external-sourcery-toolchain: forcibly create usr/lib
authorChristopher Larson <chris_larson@mentor.com>
Fri, 1 Jun 2012 22:53:58 +0000 (15:53 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 5 Jun 2012 21:53:03 +0000 (22:53 +0100)
If the usr/lib directory doesn't exist, the toolchain can fail to even try to
find crti.o in a completely different directory. This causes a failure for the
case where baselib is lib64.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/external-sourcery-toolchain.bb

index b67410b6d14fa086ab1f2faa2a201dff3857aa7c..74c82ec97870a50f6e9b0e65712415e50f7d1578 100644 (file)
@@ -24,7 +24,7 @@ PROVIDES += "\
        virtual/linux-libc-headers \
 "
 PV = "${CSL_VER_MAIN}"
-PR = "r6"
+PR = "r7"
 
 #SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/${CSL_TARGET_SYS}/arm-${PV}-${TARGET_PREFIX}i686-pc-linux-gnu.tar.bz2"
 
@@ -78,6 +78,10 @@ external_toolchain_sysroot_adjust() {
                rm -f ${SYSROOT_DESTDIR}/$dest_sysroot
                ln -s . ${SYSROOT_DESTDIR}/$dest_sysroot
        fi
+
+       # If the usr/lib directory doesn't exist, the toolchain fails to even
+       # try to find crti.o in a completely different directory (usr/lib64)
+       install -d ${SYSROOT_DESTDIR}/usr/lib
 }
 
 PACKAGES =+ "libgcc libgcc-dev libstdc++ libstdc++-dev libstdc++-staticdev linux-libc-headers linux-libc-headers-dev gdbserver gdbserver-dbg"