]> code.ossystems Code Review - openembedded-core.git/commitdiff
oprofile: Fix build when query_module is not there
authorKhem Raj <raj.khem@gmail.com>
Mon, 18 Jul 2011 22:50:59 +0000 (15:50 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Jul 2011 14:25:01 +0000 (15:25 +0100)
on 2.6 kernels we do not have query_module so warn
about it

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-kernel/oprofile/oprofile/oprofile-no-query-modules.patch [new file with mode: 0644]
meta/recipes-kernel/oprofile/oprofile_0.9.6.bb

diff --git a/meta/recipes-kernel/oprofile/oprofile/oprofile-no-query-modules.patch b/meta/recipes-kernel/oprofile/oprofile/oprofile-no-query-modules.patch
new file mode 100644 (file)
index 0000000..c9d7cd6
--- /dev/null
@@ -0,0 +1,29 @@
+disable portions which use query_module on 2.6 kernel this is not available
+in OE we dont support 2.4 anyway
+
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: oprofile-0.9.6/daemon/liblegacy/opd_kernel.c
+===================================================================
+--- oprofile-0.9.6.orig/daemon/liblegacy/opd_kernel.c  2009-11-24 07:25:17.000000000 -0800
++++ oprofile-0.9.6/daemon/liblegacy/opd_kernel.c       2011-07-18 10:08:39.863798825 -0700
+@@ -270,6 +270,9 @@
+  */
+ static void opd_drop_module_sample(unsigned long eip)
+ {
++      verbprintf(vmodule, "query_module not available on linux-2.6: %s\n", strerror(EPERM));
++
++#if   0
+       char * module_names;
+       char * name;
+       size_t size = 1024;
+@@ -307,6 +310,7 @@
+       if (module_names)
+               free(module_names);
++#endif
+ }
index 603500d428d5e7c57af7a8f8168f46b0af052133..0f154c8cec7d8762d82b98f86af410bd0f90d831 100644 (file)
@@ -19,10 +19,11 @@ FILES_${PN} = "${bindir} ${libdir}/${BPN}/lib*.so.* ${datadir}/${BPN}"
 FILES_${PN}-dev += "${libdir}/${BPN}/lib*.so ${libdir}/${BPN}/lib*.la"
 FILES_${PN}-staticdev += "${libdir}/${BPN}/lib*.a"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
            file://opstart.patch \
+           file://oprofile-no-query-modules.patch \
            file://acinclude.m4"
 
 SRC_URI[md5sum] = "4e407093ac06200185d5a5e6437d7242"