]> code.ossystems Code Review - openembedded-core.git/commitdiff
bmap-tools: fix RDEPENDS and update SRC_URI
authorTim Orling <timothy.t.orling@linux.intel.com>
Sat, 23 Dec 2017 02:46:17 +0000 (18:46 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 2 Jan 2018 17:24:15 +0000 (17:24 +0000)
* RDEPENDS are now all the python3 versions
* Upstream SRC_URI has moved to github.com/intel/bmap-tools
* Missing RDEPENDS on python3-setuptools added
  - Provides import for pkg_resources

Fixes [YOCTO #12148]

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/bmap-tools/bmap-tools_3.4.bb

index 7454f9db7510d5562b209df7ae58762f79e72330..70b6e91347b3a941366de143e205ef4e7b55b255 100644 (file)
@@ -9,12 +9,12 @@ SECTION = "console/utils"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
-SRC_URI = "git://github.com/01org/bmap-tools.git"
+SRC_URI = "git://github.com/intel/bmap-tools.git"
 SRCREV = "9dad724104df265442226972a1e310813f9ffcba"
 
 S = "${WORKDIR}/git"
 
-RDEPENDS_${PN} = "python-core python-compression python-mmap"
+RDEPENDS_${PN} = "python3-core python3-compression python3-mmap python3-setuptools"
 
 inherit python3native
 inherit setuptools3