]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add new empathy
authorRoss Burton <ross@openedhand.com>
Fri, 27 Jul 2007 09:44:33 +0000 (09:44 +0000)
committerRoss Burton <ross@openedhand.com>
Fri, 27 Jul 2007 09:44:33 +0000 (09:44 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2238 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/telepathy/empathy-0.9/no-gnome.diff [new file with mode: 0644]
meta/packages/telepathy/empathy_0.9.bb [new file with mode: 0644]

diff --git a/meta/packages/telepathy/empathy-0.9/no-gnome.diff b/meta/packages/telepathy/empathy-0.9/no-gnome.diff
new file mode 100644 (file)
index 0000000..cb9208c
--- /dev/null
@@ -0,0 +1,47 @@
+Index: src/empathy.c
+===================================================================
+--- src/empathy.c.orig 2007-07-25 13:42:16.000000000 +0100
++++ src/empathy.c      2007-07-25 13:42:47.000000000 +0100
+@@ -28,9 +28,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+-#include <libgnome/gnome-program.h>
+-#include <libgnomeui/gnome-ui-init.h>
+-
+ #include <libtelepathy/tp-conn.h>
+ #include <libtelepathy/tp-chan.h>
+ #include <libmissioncontrol/mc-account.h>
+@@ -151,7 +148,6 @@
+       McAccountMonitor  *monitor;
+       EmpathyIdle       *idle;
+       EmpathyChandler   *chandler;
+-      GnomeProgram      *program;
+       gboolean           no_connect = FALSE;
+       GOptionContext    *context;
+       GOptionEntry       options[] = {
+@@ -170,15 +166,7 @@
+       g_option_context_add_main_entries (context, options, GETTEXT_PACKAGE);
+       g_set_application_name (PACKAGE_NAME);
+-
+-      program = gnome_program_init ("empathy",
+-                                    PACKAGE_VERSION,
+-                                    LIBGNOMEUI_MODULE,
+-                                    argc, argv,
+-                                    GNOME_PROGRAM_STANDARD_PROPERTIES,
+-                                    "goption-context", context,
+-                                    GNOME_PARAM_HUMAN_READABLE_NAME, PACKAGE_NAME,
+-                                    NULL);
++      gtk_init (&argc, &argv);
+       gtk_window_set_default_icon_name ("empathy");
+       gtk_icon_theme_append_search_path (gtk_icon_theme_get_default (),
+@@ -221,7 +209,6 @@
+       g_object_unref (mc);
+       g_object_unref (idle);
+       g_object_unref (icon);
+-      g_object_unref (program);
+       return EXIT_SUCCESS;
+ }
diff --git a/meta/packages/telepathy/empathy_0.9.bb b/meta/packages/telepathy/empathy_0.9.bb
new file mode 100644 (file)
index 0000000..f9f1eca
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade gnome-vfs"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+PR="r1"
+
+inherit gnome gtk-icon-cache
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/empathy/0.9/empathy-${PV}.tar.bz2 \
+           file://no-gnome.diff;patch=1;pnum=0"
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+        ${datadir}/dbus-1/services/*.service \
+        ${datadir}/telepathy/managers/*.chandler"