]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: Fix parallel make race
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 28 Jun 2018 13:39:35 +0000 (13:39 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 28 Jun 2018 22:33:55 +0000 (23:33 +0100)
Builds keep failing with a race over the generated header file, fix it!

[YOCTO #12828]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/files/parallel-make-race-fix.patch [new file with mode: 0644]
meta/recipes-graphics/mesa/mesa_18.1.2.bb

diff --git a/meta/recipes-graphics/mesa/files/parallel-make-race-fix.patch b/meta/recipes-graphics/mesa/files/parallel-make-race-fix.patch
new file mode 100644 (file)
index 0000000..d212a55
--- /dev/null
@@ -0,0 +1,26 @@
+There is a parallel make build issue in src/egl/drivers/dri2/
+for wayland builds. Can be reproduced with:
+
+$ rm src/egl/drivers/dri2/*.h src/egl/drivers/dri2/platform_wayland.lo
+$ make -C src/egl/ drivers/dri2/platform_wayland.lo
+
+../../../mesa-18.1.2/src/egl/drivers/dri2/platform_wayland.c:50:10: fatal error: linux-dmabuf-unstable-v1-client-protocol.h: No such file or directory
+
+This patch adds the missing dependency.
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+
+Upstream-Status: Submitted (https://lists.freedesktop.org/archives/mesa-dev/2018-June/198889.html)
+
+Index: mesa-18.1.2/src/egl/Makefile.am
+===================================================================
+--- mesa-18.1.2.orig/src/egl/Makefile.am
++++ mesa-18.1.2/src/egl/Makefile.am
+@@ -80,6 +80,7 @@ drivers/dri2/linux-dmabuf-unstable-v1-cl
+ if HAVE_PLATFORM_WAYLAND
+ drivers/dri2/linux-dmabuf-unstable-v1-protocol.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
+ drivers/dri2/egl_dri2.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
++drivers/dri2/platform_wayland.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
+ AM_CFLAGS += $(WAYLAND_CLIENT_CFLAGS)
+ libEGL_common_la_LIBADD += $(WAYLAND_CLIENT_LIBS)
index 2c06b1eb7ba370f03f09b7a3e33d89cf463a3678..9a9a2b25623fe623269d5265fd09ffbeb7c2ef66 100644 (file)
@@ -8,6 +8,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
            file://0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
            file://0006-Use-Python-3-to-execute-the-scripts.patch \
            file://0007-dri-i965-Add-missing-time.h-include.patch \
+           file://parallel-make-race-fix.patch \
 "
 
 SRC_URI[md5sum] = "a2d4f031eb6bd6111d44d84004476918"