]> code.ossystems Code Review - openembedded-core.git/commitdiff
elfutils: Disable the unnecessary check in iconv.m4
authorRoy Li <rongqing.li@windriver.com>
Tue, 12 May 2015 07:38:09 +0000 (15:38 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 14 May 2015 10:41:10 +0000 (11:41 +0100)
Disable the test "Test against HP-UX 11.11 bug: No converter from EUC-JP
to UTF-8 is provided" since we don't support HP-UX and if the euc-jp is
not installed on the host, the dependence will be built without iconv
support and will cause guild-native building fail.

The patch is similar as 0470bd7a9658d3[libunistring: remove the test to
convert euc-jp in configure]

Signed-off-by: Roy Li <rongqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/elfutils/elfutils-0.161/0001-remove-the-unneed-checking.patch [new file with mode: 0644]
meta/recipes-devtools/elfutils/elfutils_0.161.bb

diff --git a/meta/recipes-devtools/elfutils/elfutils-0.161/0001-remove-the-unneed-checking.patch b/meta/recipes-devtools/elfutils/elfutils-0.161/0001-remove-the-unneed-checking.patch
new file mode 100644 (file)
index 0000000..5be92d7
--- /dev/null
@@ -0,0 +1,38 @@
+Disable the test to convert euc-jp
+
+Remove the test "Test against HP-UX 11.11 bug:
+No converter from EUC-JP to UTF-8 is provided"
+since we don't support HP-UX and if the euc-jp is not
+installed on the host, the dependence will be built without
+iconv support and will cause guild-native building fail.
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ m4/iconv.m4 | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/m4/iconv.m4 b/m4/iconv.m4
+index a503646..299f1eb 100644
+--- a/m4/iconv.m4
++++ b/m4/iconv.m4
+@@ -159,6 +159,7 @@ int main ()
+       }
+   }
+ #endif
++#if 0
+   /* Test against HP-UX 11.11 bug: No converter from EUC-JP to UTF-8 is
+      provided.  */
+   if (/* Try standardized names.  */
+@@ -170,6 +171,7 @@ int main ()
+       /* Try HP-UX names.  */
+       && iconv_open ("utf8", "eucJP") == (iconv_t)(-1))
+     result |= 16;
++#endif
+   return result;
+ }]])],
+         [am_cv_func_iconv_works=yes],
+-- 
+2.0.1
+
index e111b34a8a32c39674e7efe6defff819a019f598..70a3c16cf530fbc2a27e15aa9f9e46967cc5c707 100644 (file)
@@ -17,6 +17,7 @@ SRC_URI += "\
         file://fixheadercheck.patch \
         file://0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch \
         file://0001-libelf-Fix-dir-traversal-vuln-in-ar-extraction.patch \
+        file://0001-remove-the-unneed-checking.patch \
 "
 
 # pick the patch from debian