]> code.ossystems Code Review - openembedded-core.git/commitdiff
which: use BPN for alternatives
authorMark Hatle <mark.hatle@windriver.com>
Tue, 22 May 2012 17:37:16 +0000 (12:37 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 May 2012 09:43:41 +0000 (10:43 +0100)
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-extended/which/which_2.18.bb
meta/recipes-extended/which/which_2.20.bb

index f87929b334723a37f975ae3813222e14cf6d966f..d54e776407ce0ec5050afa9019abf7618aedabc8 100644 (file)
@@ -27,10 +27,10 @@ do_configure_prepend() {
        sed -i "s#${OLD}#${NEW}#g" `grep -rl ${OLD} ${S}`
 }
 do_install_append() {
-       mv ${D}/${bindir}/which ${D}/${bindir}/which.${PN}
+       mv ${D}/${bindir}/which ${D}/${bindir}/which.${BPN}
 }
 
 ALTERNATIVE_NAME = "which"
-ALTERNATIVE_PATH = "which.${PN}"
+ALTERNATIVE_PATH = "which.${BPN}"
 ALTERNATIVE_PRIORITY = "100"
 
index a4e860b6c949ae2feda8f59b10d77d5e0562eebd..9b4394331c4b8e0e154103c0c3765902c76400fd 100644 (file)
@@ -24,9 +24,9 @@ do_configure_prepend() {
 
 do_install() {
        autotools_do_install
-       mv ${D}${bindir}/which ${D}${bindir}/which.${PN}
+       mv ${D}${bindir}/which ${D}${bindir}/which.${BPN}
 }
 
 ALTERNATIVE_NAME = "which"
-ALTERNATIVE_PATH = "which.${PN}"
+ALTERNATIVE_PATH = "which.${BPN}"
 ALTERNATIVE_PRIORITY = "100"