]> code.ossystems Code Review - openembedded-core.git/commitdiff
irda-utils: use update-rc.d class (from OE)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 30 Jan 2008 21:22:16 +0000 (21:22 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 30 Jan 2008 21:22:16 +0000 (21:22 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3642 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/irda-utils/irda-utils_0.9.16.bb

index 95a15d7d23adff4fde2ed285697b65adfbf8544d..19bcdf397c6623210710db339280116e3ba2718e 100644 (file)
@@ -3,7 +3,7 @@ IrDA allows communication over Infrared with other devices \
 such as phones and laptops."
 SECTION = "base"
 LICENSE = "GPL"
-PR = "r6"
+PR = "r8"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
           file://configure.patch;patch=1 \
@@ -12,7 +12,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
 
 export SYS_INCLUDES="-I${STAGING_INCDIR}"
 
-inherit autotools update-rc.d
+inherit autotools
 
 INITSCRIPT_NAME = "irattach"
 INITSCRIPT_PARAMS = "defaults 20"
@@ -28,5 +28,5 @@ do_install () {
        oe_runmake -C irdaping ROOT="${D}" install
 
        install -d ${D}${sysconfdir}/init.d
-       install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/irattach
+       install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
 }