]> code.ossystems Code Review - openembedded-core.git/commitdiff
self-hosted-image: Increase space for build and allow builder user sudo access
authorSaul Wold <sgw@linux.intel.com>
Wed, 4 Apr 2012 00:33:42 +0000 (17:33 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Apr 2012 16:17:11 +0000 (17:17 +0100)
We need to have about 40G to do a full sato build even with rm_work enabled
Add sudo priveleges inorder to allow the builder user to setup the tap/tun
devices needed by runqemu

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/images/self-hosted-image.bb

index 28221892a3987adc250c338d8afc655f968d1a63..1db6a7a3b2666ea871e40e567c2d0084f3f2389f 100644 (file)
@@ -4,15 +4,12 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
-PR = "r8"
+PR = "r9"
 
 IMAGE_FEATURES += "x11-mini package-management"
 
-# Ensure there's enough space to do a core-image-minimal build, with rm_work enabled
-IMAGE_ROOTFS_EXTRA_SPACE = "1048576"
-#IMAGE_ROOTFS_EXTRA_SPACE = "2621440"
-#IMAGE_ROOTFS_EXTRA_SPACE = "20971520"
-#IMAGE_ROOTFS_EXTRA_SPACE = "5242880"
+# Ensure there's enough space to do a core-image-sato build, with rm_work enabled
+IMAGE_ROOTFS_EXTRA_SPACE = "41943040"
 
 # Do a quiet boot with limited console messages
 APPEND += "quiet"
@@ -50,6 +47,9 @@ fakeroot do_populate_poky_src () {
        chown builder.builder ${IMAGE_ROOTFS}/home/builder/pseudo
 
        chown -R builder.builder  ${IMAGE_ROOTFS}/home/builder/poky
+
+       # Allow builder to use sudo to setup tap/tun
+       echo "builder ALL=(ALL) NOPASSWD: ALL" >> /etc/sudoers
 }
 
 IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "