]> code.ossystems Code Review - openembedded-core.git/commitdiff
unzip: Add ALTERNATIVE configuration
authorSaul Wold <sgw@linux.intel.com>
Thu, 12 Mar 2015 19:58:17 +0000 (12:58 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 20 Mar 2015 10:59:05 +0000 (10:59 +0000)
Since busybox also provides the unzip command use the update-alternatives
mechanism to address this.

[YOCTO #7446]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/unzip/unzip_6.0.bb

index 33c20f8b4ccfff8288c37e39809497d57a512fdb..e203c069f4f6799942f03bd11a183670236a82ab 100644 (file)
@@ -35,4 +35,11 @@ do_install() {
        rmdir ${D}${prefix}/man/
 }
 
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+
+ALTERNATIVE_${PN} = "unzip"
+ALTERNATIVE_LINK_NAME[unzip] = "${bindir}/unzip"
+
 BBCLASSEXTEND = "native"