]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-nose: add a recipe
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Wed, 11 May 2016 13:46:04 +0000 (16:46 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 1 Jun 2016 07:04:11 +0000 (08:04 +0100)
This is needed for updating piglit to use Python 3.
Python 2 based recipe can be later moved to meta-oe.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
meta/recipes-devtools/python/python3-nose_1.3.7.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python3-nose_1.3.7.bb b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
new file mode 100644 (file)
index 0000000..a45d2f2
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY = "Extends Python unittest to make testing easier"
+DESCRIPTION = "nose extends the test loading and running features of unittest, \
+making it easier to write, find and run tests."
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://lgpl.txt;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+SRC_URI = "http://pypi.python.org/packages/source/n/nose/nose-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "4d3ad0ff07b61373d2cefc89c5d0b20b"
+SRC_URI[sha256sum] = "f1bffef9cbc82628f6e7d7b40d7e255aefaa1adb6a1b1d26c69a8b79e6208a98"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/nose/"
+UPSTREAM_CHECK_REGEX = "/nose/(?P<pver>(\d+[\.\-_]*)+)"
+
+S = "${WORKDIR}/nose-${PV}"
+
+inherit setuptools3
+
+RDEPENDS_${PN}_class-target = "\
+  python3-unittest \
+  "
+
+BBCLASSEXTEND = "native nativesdk"