]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston-init: Add module support for the weston-start helper
authorOtavio Salvador <otavio@ossystems.com.br>
Wed, 18 May 2016 16:40:45 +0000 (13:40 -0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 21 May 2016 21:21:30 +0000 (22:21 +0100)
To make weston-start more flexible we now support module loading. For
such modules, following functions can be used:

 - add_weston_argument
 - add_openvt_argument

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/wayland/weston-init.bb
meta/recipes-graphics/wayland/weston-init/weston-start

index 3a2251e69a0c7a0b5f4724998e28f23f60f04582..e4e2701af734a85feda97c726bafc5bf8ab91918 100644 (file)
@@ -11,7 +11,10 @@ S = "${WORKDIR}"
 do_install() {
        install -Dm755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
        install -Dm0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+
+       # Install weston-start script
        install -Dm755 ${WORKDIR}/weston-start ${D}${bindir}/weston-start
+       sed -i 's,@DATADIR@,${datadir},g' ${D}${bindir}/weston-start
 }
 
 inherit allarch update-rc.d distro_features_check systemd
index dc2b1efc7806908d84fb65ebc168599b6807099d..4aa7c66d3bbbb3fd43ca75dbc9569688c14f314f 100755 (executable)
@@ -9,6 +9,19 @@ usage() {
 EOF
 }
 
+## Module support
+modules_dir=@DATADIR@/weston-start
+
+# Add weston extra argument
+add_weston_argument() {
+       weston_args="$weston_args $1"
+}
+
+# Add openvt extra argument
+add_openvt_argument() {
+       openvt_args="$openvt_args $1"
+}
+
 if test $# -lt 2; then
        usage
        exit 1
@@ -32,6 +45,19 @@ done
 
 weston_args=$*
 
+# Load and run modules
+if [ -d "$modules_dir" ]; then
+       for m in "$modules_dir"/*; do
+               # Skip backup files
+               if [ "`echo $m | sed -e 's/\~$//'`" != "$m" ]; then
+                       continue
+               fi
+
+               # process module
+               . $m
+       done
+fi
+
 if test -z "$XDG_RUNTIME_DIR"; then
     export XDG_RUNTIME_DIR=/run/user/`id -u`
     mkdir --parents $XDG_RUNTIME_DIR